Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12616 closed enhancement (no change required)

HaikuDepot search term

Reported by: lorglas Owned by: stippi
Priority: normal Milestone: Unscheduled
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

Hello there, I noticed when entering the depot in a search box, which are all available apps displayed. However, I expect the Apps with A, not all. It would be better if you were since the characters * for all app.

Attachments (1)

Haikudepot_Search_term.png (96.8 KB) - added by lorglas 3 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 3 years ago by diver

Component: - GeneralApplications/HaikuDepot
Description: modified (diff)
Keywords: HaikuDepot search term removed
Owner: changed from nobody to stippi

Not sure what you mean. Could you expand on that?

Changed 3 years ago by lorglas

Attachment: Haikudepot_Search_term.png added

comment:2 Changed 3 years ago by lorglas

I've added a screenshot , I hope it is now understandable .

comment:3 Changed 3 years ago by taos

Is it possible that descriptions are searched, too? Most of the descriptions in the screenshot contain an "a" somewhere.

comment:4 Changed 3 years ago by diver

This is exactly what's happening here and it was implemented on purpose. This way you can find packages which name or summary you forgot or might not even know.

comment:5 Changed 3 years ago by humdinger

Resolution: no change required
Status: newclosed

I'll close the ticket then. If the search box is used as intended, i.e. searching for one or more keywords, it works pretty well. Alphabetical listing of all applictions isn't really useful when the number of packages gets bigger. Limiting to certain categories is also helpful, though I think this isn't yet completely implemented yet.

comment:6 Changed 3 years ago by tangobravo

A drop down of what to search (Name / Keywords / Description, all can be toggled independently) might be a handy addition.

comment:7 Changed 3 years ago by lorglas

Why it works correct, when I enter an b or c, then i see the apps with the b or c first. It works not completly correct.

comment:8 Changed 3 years ago by lelldorin

But should not a search option by input "a" also first all found packages begin with "a" first appear? The current approach irritated and is not the standard on other systems or applications. This should be reconsidered time?

Last edited 3 years ago by lelldorin (previous) (diff)

comment:9 Changed 3 years ago by humdinger

The "Search term" text box doesn't filter the package name column, but filters all packages that contain the search string(s) in their name|summary|description. It's not useful to enter one letter, because pretty much every name|summary|description contains every letter of the alphabet.
From a practical point of view, most people don't look for "some application beginning with 'A'", but search for some category of application or feature, like "graphic", "vector", "font" or "PDF" etc.

comment:10 Changed 3 years ago by lelldorin

Case study: Seeking a known program but me reminds me of the name no longer correctly ( spelling ) , I know but it starts as with D , then I give " d " in the search to find it , here would bother me if I had to scroll until " d " to find it .

Last edited 3 years ago by lelldorin (previous) (diff)

comment:11 Changed 3 years ago by humdinger

I'm still not convinced, sorry. :)
If you can't seem to hit on a word used in name/summary/description, you can limit your search to the category. That should cut short the result list. If you don't want to try all that, the worst that will happen is that you have to got through the trouble of scrolling the list manually to the letter you remember.

I suspect that the case where you really only remember the first letter and not at least one syllable in the name of an application is very rare. I doubt complicating the search algorithm is really worth it. But if more people think differently, I'll re-open the ticket and we'll see what a dev can come up with.

Note: See TracTickets for help on using tickets.