Opened 3 years ago

Closed 3 years ago

#12634 closed bug (fixed)

The syslog is continuously flooded with the same messages.

Reported by: Giova84 Owned by: kallisti5
Priority: normal Milestone: Unscheduled
Component: Drivers/Disk Version: R1/Development
Keywords: Cc:
Blocked By: #12415 Blocking:
Has a Patch: yes Platform: x86

Description

Hi, Yesterday I was looking at the folder /var/log/ and I noticed that the syslog file is continuously growing: it never stops. I made a short explicative video (attached to this ticket): in this video we can see the output of "tail -f /var/log/syslog" and the syslog file which continuously grows. It quickly reach the size of 512 KB, the file is created again, and then this strange behaviour is incessantly repeated. I also attach the syslog itself.

I choose "General" as Component, because I have no idea about the culprit.

hrev50067

Attachments (3)

syslog (172.8 KB) - added by Giova84 3 years ago.
syslog_video.mpg (978.0 KB) - added by Giova84 3 years ago.
0001-ahci-Disable-tracing-make-tracing-more-chatty.patch (11.3 KB) - added by kallisti5 3 years ago.
Patch v1, to be tested

Download all attachments as: .zip

Change History (14)

Changed 3 years ago by Giova84

Attachment: syslog added

Changed 3 years ago by Giova84

Attachment: syslog_video.mpg added

comment:1 Changed 3 years ago by diver

Blocked By: 12415 added
Resolution: duplicate
Status: newclosed

comment:2 Changed 3 years ago by kallisti5

Resolution: duplicate
Status: closedreopened

comment:3 Changed 3 years ago by kallisti5

Component: - GeneralDrivers/Disk

This is a cosmetic issue. AHCI by design resets the port over and over until media is present. mmlr previously simply hid the errors, however we should see if there is a more proper way to not spam when no media is present. (I really hate doing "if no media is present, hide this error... if no media is present hide that error")

comment:4 Changed 3 years ago by kallisti5

Owner: changed from nobody to kallisti5
Status: reopenedassigned

comment:5 Changed 3 years ago by Gedrin

Its annoying to read the syslog now. Maybe write only the first port reset until a status change?

comment:6 Changed 3 years ago by Giova84

Hi Kallisti, any news about the solution for this ticket? I also heard of other people which find hard (and so also impossible, sometimes) to read the syslog, especially for bug-hunting purposes.

comment:7 Changed 3 years ago by kallisti5

I'll work on hiding those messages tonight. I've been testing the AHCI code on physical machines that used to be broken and it is working now... so i'm pretty happy with the stability at this point. I'm reluctant to make any other changes for a while (besides hiding those messages)

Changed 3 years ago by kallisti5

Patch v1, to be tested

comment:8 Changed 3 years ago by kallisti5

Has a Patch: set

comment:9 Changed 3 years ago by kallisti5

Patch (+ a bit extra) pushed in hrev50397. That should make the ahci stack show better data when tracing is enabled, and shutup when tracing is disabled. (serious errors are a bit more chatty though)

Let me know if it helps.

comment:10 Changed 3 years ago by Giova84

Hi Kallisti,

now I'm on hrev50397 and the syslog is no longer flooded as before: you did a good work, thank you for your efforts!

comment:11 Changed 3 years ago by pulkomandy

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.