Opened 6 years ago

Closed 6 years ago

#12692 closed bug (duplicate)

pkgman update stalls out on x86_64 nightlies

Reported by: Eschaton Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Network & Internet Version: R1/Development
Keywords: Cc:
Blocked By: #1073 Blocking:
Platform: x86-64

Description

I’m trying to run x86_64 Haiku nightlies on VMware, and “pkgman update” stalls out when I try to update to a newer system. I’m on an extremely fast connection, and have been waiting at 89% on haiku-hrev1~alpha4_pm_hrev50196-1-x86_64.hpkg for a couple of minutes now.

I have no idea how to investigate, I’m assuming that the issue may be with networking itself on x86_64. Let me know what logs I should capture or whatever.

Change History (4)

comment:1 by diver, 6 years ago

I had the same problem the other day on x86_gcc2 and the "fix" was to switch nat to bridge in VM settings.

comment:2 by mmlr, 6 years ago

This sounds a lot like an MTU issue. Try lowering the MTU using ifconfig <device> mtu 1400 and check if the problem persists. If setting a lower MTU fixes it, then this is a duplicate of #1073.

comment:3 by Eschaton, 6 years ago

Lowering the MTU seems to be working, so this does sound like a dup of #1073.

Thanks!

comment:4 by mmlr, 6 years ago

Blocked By: 1073 added
Resolution: duplicate
Status: newclosed

Thanks for checking, closing as duplicate.

Note: See TracTickets for help on using tickets.