Opened 4 years ago

Closed 12 days ago

#12709 closed bug (invalid)

Supported wireless & wired Nics not recognized under April 5th, 2016 build for x86_gcc2

Reported by: domcaf Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Network & Internet/Wireless Version: R1/Development
Keywords: AR2413 AR2414 RTL8139 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Supported wireless & wired Nics not recognized under April 5th, 2016 build for x86_gcc2.

The Qualcomm_Atheros wireless nic, AR2413/AR2414 listed at https://www.haiku-os.org/guides/daily-tasks/wireless#hardware-notes not listed/recongized in Network configuration utility.

Also, the ethernet nic, DLink, RTL8139, in same box also not recognized.

Problem reproduced on real/physical hardware. Please see attached screendumps and contact me if more info is needed.

Attachments (7)

dsktop-haiku-wifi.jpeg (191.6 KB ) - added by domcaf 4 years ago.
Screendump showing diagnositic info for wireless nic
dsktop-haiku-ethernet.jpeg (191.4 KB ) - added by domcaf 4 years ago.
Screendump of diagnostic info for wired/ethernet nic
dsktop-ifconfig-output.txt (367 bytes ) - added by domcaf 4 years ago.
Output from running ifconfig from terminal.
dsktop-haiku-syslog.txt (338.6 KB ) - added by domcaf 4 years ago.
syslog
bios-sys-ver-info.jpg (2.8 MB ) - added by domcaf 4 years ago.
Bios system info
bios-device-enumeration.jpg (3.7 MB ) - added by domcaf 4 years ago.
Bios device enumeration
bios-bus-options.jpg (1.9 MB ) - added by domcaf 4 years ago.
Bios bus mastering option

Change History (21)

by domcaf, 4 years ago

Attachment: dsktop-haiku-wifi.jpeg added

Screendump showing diagnositic info for wireless nic

by domcaf, 4 years ago

Attachment: dsktop-haiku-ethernet.jpeg added

Screendump of diagnostic info for wired/ethernet nic

comment:1 by diver, 4 years ago

Could you attach your syslog?

by domcaf, 4 years ago

Attachment: dsktop-ifconfig-output.txt added

Output from running ifconfig from terminal.

by domcaf, 4 years ago

Attachment: dsktop-haiku-syslog.txt added

syslog

in reply to:  1 comment:2 by domcaf, 4 years ago

Replying to diver:

Could you attach your syslog?

syslog and ifconfig output have been attached.

Thanks.

comment:3 by diver, 4 years ago

Relevant messages from the syslog:

[atheroswifi] (ath_pci) bus_alloc_resource(3, [16], 0x0, 0xffffffff, 0x1,0x2)
[atheroswifi] atheroswifi: /dev/net/atheroswifi/0
[net/atheroswifi/0] unable to attach hardware; HAL status 3
[rtl8139] (rl) bus_alloc_resource(4, [16], 0x0, 0xffffffff, 0x1,0x2)
[rtl8139] (rl) bus_alloc_resource(1, [0], 0x0, 0xffffffff, 0x1,0x6)
[rtl8139] (rl) reset never completed!
[rtl8139] (rl) unknown device ID: ffff assuming 8139
[rtl8139] (rl) attaching PHYs failed

Maybe you can try toggling PnP OS in BIOS? See also https://forums.freebsd.org/threads/17122/

Last edited 4 years ago by diver (previous) (diff)

by domcaf, 4 years ago

Attachment: bios-sys-ver-info.jpg added

Bios system info

by domcaf, 4 years ago

Attachment: bios-device-enumeration.jpg added

Bios device enumeration

by domcaf, 4 years ago

Attachment: bios-bus-options.jpg added

Bios bus mastering option

comment:4 by domcaf, 4 years ago

Unfortunately, the bios on the hardware that I reported the problem on does not have a PNP-OS option. It's an old system that most folks would think only useful as a door stop or boat anchor. This hardware does run the most recent 32-bit-Intel version of Lubuntu, http://lubuntu.net, successfully from a network hardware perspective and also plays mp3's successfully with mpg123 utility for Linux. I uploaded some screenshots of bios info for the hardware for whatever informational value they might have; I hope it helps. "A CPU is a terrible thing to waste.".

Regards & Thanks!

comment:5 by diver, 4 years ago

Maybe you could try turning off ACPI in the bootloader?

in reply to:  5 comment:6 by domcaf, 4 years ago

Replying to diver:

Maybe you could try turning off ACPI in the bootloader?

Disabling ACPI in bootloader did the trick. Both wired/wireless nics now seen by network config and wireless networking now functioning. Will verify wired functionality in next day or so and log a note to case. Thanks!

comment:7 by domcaf, 4 years ago

Wired nic verified as working as well.

comment:8 by domcaf, 4 years ago

I consider this issue resolved. I do not have any UI options to close/resolve this issue/ticket otherwise I would do so.

comment:9 by diver, 4 years ago

We should leave it open, clearly, something is wrong with ACPI or kernel. Probably one of the developers can ask you to provide additional info.

comment:10 by diver, 4 years ago

Possibly related messages from the syslog:

no local APIC present, not attempting SMP init
disabling msi due to missing apic

comment:11 by domcaf, 4 years ago

Ok, we can leave this issue/ticket open and I'll do what I can to provide more diagnostic info when someone asks for it..

comment:12 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:13 by waddlesplash, 11 months ago

Please retest under a recent nightly.

comment:14 by waddlesplash, 12 days ago

Resolution: invalid
Status: assignedclosed

No reply.

Note: See TracTickets for help on using tickets.