Opened 3 years ago

Closed 3 years ago

#12712 closed bug (invalid)

on hrev50198 I am no longer able to play audio files

Reported by: Giova84 Owned by: Barrett
Priority: normal Milestone: Unscheduled
Component: Servers/media_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev50198

When I attempt to play mp3 or wav files with MediaPlayer, MediaPlayer will claim about a general system error and then will crash (debug report attached).

If I attempt to play mp3 and wav files using SoundPlay, SoundPlay is now only able to play mp3 files: will crash while opening wav files.

If I attempt to play mp3 and wav files using Mplay everything is Ok.

If i attempt to drag a wav file inside XRS (as I was able on hrev50141) nothing will happen. The XRS executable is available here: https://dev.haiku-os.org/attachment/ticket/10922/Xrs1.3unbeta2.zip

Attachments (3)

MediaPlayer-1256-debug-09-04-2016-21-50-08.report (17.0 KB) - added by Giova84 3 years ago.
SoundPlay-1350-debug-09-04-2016-21-50-45.report (36.0 KB) - added by Giova84 3 years ago.
XRS-1684-debug-09-04-2016-22-00-18.report (26.2 KB) - added by Giova84 3 years ago.

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by Giova84

comment:1 in reply to:  description ; Changed 3 years ago by Giova84

Replying to Giova84:

If i attempt to drag a wav file inside XRS (as I was able on hrev50141) nothing will happen. The XRS executable is available here: https://dev.haiku-os.org/attachment/ticket/10922/Xrs1.3unbeta2.zip

If i attempt to drag a wav file inside XRS (as I was able on hrev50141) nothing will happen, and when I quit XRS, XRS will crash too.

comment:2 in reply to:  1 Changed 3 years ago by Giova84

On Haiku-os.org (here https://www.haiku-os.org/blog/barrett/2016-04-06_streaming_support_and_mediakit_development_weekly_report_4 ) Barrett suggested me to switch to a newer nightly image:

The ticket doesn't seem related to a true media_kit issue, it's probably related to a build permission we are discussing those days, I suggest you to try a newer image.

currently I'm on hrev50216 but I am still unable to play media files on Haiku.. What can I try to check? On hrev50141 everything was fine.

comment:3 Changed 3 years ago by Giova84

Well, seems that I was able to figure out the cause of the issue.

Using pkgman, some weeks ago I added the optional repository located at https://hpkg.mlotz.ch/ Well: I removed such repository, I switched back to hrev50141 and then I updated again Haiku: now everythings works fine as before.

Why?

comment:4 Changed 3 years ago by Barrett

Resolution: invalid
Status: newclosed

I think good chances are that you installed a custom version of ffmpeg and it clashed after some Haiku update.

Closing the ticket as invalid.

Note: See TracTickets for help on using tickets.