Opened 3 years ago

Closed 7 weeks ago

#12715 closed bug (fixed)

Web+ won't upload screenshot at HDS site

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev50173.

Uploading a HVIF icon at the Haiku Depot Server works, but uploading screenshots doesn't. Andrew had a look at the HDS log:

It looks like the client (WebPositive?) may not be sending material to
the server in a reasonable time-frame?

java.io.IOException: java.util.concurrent.TimeoutException: Idle timeout
expired: 30001/30000 ms
        at
        org.eclipse.jetty.server.HttpInput$ErrorState.noContent(HttpInput.java:773)
        at org.eclipse.jetty.server.HttpInput.read(HttpInput.java:158)
        at
        org.haiku.haikudepotserver.pkg.PkgOrchestrationService.toByteArray(PkgOrchestrationService.java:105)

Uploading with QupZilla works.

Change History (5)

comment:1 Changed 3 years ago by pulkomandy

Is this still a problem with HaikuWebKit 1.5.3?

comment:2 Changed 3 years ago by humdinger

Andrew would have to look if anything has changed in the log. Uploading a screenshot hasn't changed from my point of view. The screen still greys out and remains so, nothing gets uploaded. When clicking the reload button of Web+ after a while, I see this in Terminal:

SSL error:00000005:lib(0):func(0):DH lib
MESSAGE https://depot.haiku-os.org/__jawr/js/gzip_1953476924/bundles/libs.js?:619:15: unable to add the screenshot for; armyknife
MESSAGE https://depot.haiku-os.org/__jawr/js/gzip_1953476924/bundles/libs.js?:619:15: reset the breadcrumb stack

comment:3 Changed 2 years ago by apl-haiku

I've just checked and this problem is unfortunately still happening. I have run the application server (HDS) on another host locally without a reverse-proxy in place. It _seems_ that Web+ is simply blocking when it does the POST with the payload. The timeout noted above is not relevant as this is most likely the Apache load-balancer timing out the request.

The place in the JS code where the problem is happening is;

...
return $http({
  cache: false,
  method: 'POST',
  url: '/' + SEGMENT_SCREENSHOT + '/'+pkg.name+'/add?format=png',
  headers: _.extend(
    { 'Content-Type' : 'image/png' },
    PkgScreenshot.headers),
  data: screenshotFile
}).then(
...

The data is a JS File (https://developer.mozilla.org/en/docs/Web/API/File) object. The logic is in the file "pkgscreenshotservice.js". If anybody wants to hit HDS without getting minified JS files back then I can make that happen for a period of time.

Also note that a python script has been added to the HDS repo in order to upload screenshots. This is a work-around until this can be investigated.

Last edited 2 years ago by apl-haiku (previous) (diff)

comment:4 Changed 13 months ago by humdinger

Still not possible to upload screenshots with haikuwebkit 1.6.4.

comment:5 Changed 7 weeks ago by humdinger

Resolution: fixed
Status: newclosed

Fixed with haikuwebkit 1.6.9 or an updated HDS... :) Thanks!

Note: See TracTickets for help on using tickets.