Opened 3 years ago

Closed 3 years ago

#12722 closed bug (duplicate)

Port consumption with maps.google.fr

Reported by: ttcoder Owned by: jua
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #12614 Blocking:
Has a Patch: no Platform: All

Description

Monitor ports with watch sysinfo -ports beside the Web+ window

Zoom in and out for a few seconds; if you close the tab soon enough, ports are returned; if you wait too long, W+ closes down without warning and syslog reports "ports exhausted, could not create debugger"

For whatever it's worth...

Change History (3)

comment:1 Changed 3 years ago by pulkomandy

Owner: changed from pulkomandy to jua
Status: newassigned

Reassigning to Jua as this is most likely creating a lot of BBitmaps for tiles. Maybe we have a way to more lazily create the offscreen bitmaps in that case or disable/limit the pooling in WebKit? (there is a pool of TextureBitmap IIRC, which each hold a BBitmap ready for use with offscreen drawing).

comment:2 Changed 3 years ago by vidrep

Sounds like a duplicate of ticket #12614

comment:3 Changed 3 years ago by pulkomandy

Blocked By: 12614 added
Resolution: duplicate
Status: assignedclosed
Note: See TracTickets for help on using tickets.