Opened 12 years ago

Closed 11 years ago

#1273 closed bug (invalid)

Running SerialConnect on Haiku

Reported by: kaoutsis Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Purpose: serial debugging Haiku from another haiku machine. Useful also for network tests.

Currently SerialConnect says: BShell: can't find the shell

Attachments (1)

screen2.png (84.8 KB) - added by kaoutsis 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by kaoutsis

Attachment: screen2.png added

comment:1 Changed 12 years ago by jackburton

I think the problem is that our terminal has a different signature than the hrev5 one. Summon suffers from the same problem.

comment:2 in reply to:  1 Changed 12 years ago by kaoutsis

Replying to jackburton:

I think the problem is that our terminal has a different signature than the hrev5 one. Summon suffers from the same problem.

Some time ago, (~6 months), while i was setting up a custom null modem cable, from one hrev5 machine, to another hrev5, something went wrong, and i get this message, from the hrev5 terminal (running of course hrev5): BShell: can't find the shell and the terminal was unusable; the problem go away, went reinstall the upgrade 5.0.3 pkg, and the terminal became usable again. I still do not know that this message is about.

comment:3 Changed 11 years ago by kaoutsis

Resolution: invalid
Status: newclosed

hrev25184, now gives: BShell: can't open a pty

So, closing for the same reason as for #2161

Note: See TracTickets for help on using tickets.