Opened 12 years ago

Closed 9 years ago

#1275 closed bug (fixed)

Playing aiff type sounds locks up system

Reported by: cebif Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Kits/Media Kit Version: R1/pre-alpha1
Keywords: Cc: haiku@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Every time I play a aiff type sound file in Media Player or the Sounds preferences application, the whole desktop becomes unresponsive. I can still move the mouse pointer around but cannot click anything. The keyboard is also unresponsive. The sound plays fully right through but everything locks up after that. Playing wav files does not cause a problem. I copied some Beos aiff and wav sounds from a R4.5 install CD, into an sounds/ folder that I created in: /Haiku/beos/etc. The image I was using was hrev21301 on its own drive partition.

Attachments (1)

BeBeep.aiff (120.0 KB) - added by cebif 11 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by marcusoverhagen

Component: Kits/Game KitKits/Media Kit
Status: newassigned

comment:2 Changed 11 years ago by mauricek

Cc: haiku@… added

Is this still reproducable? While I was trying to verify this some weeks ago, I was not able to do so.

Could you by chance provide a file which forces this behavior?

comment:3 Changed 11 years ago by cebif

This is still a problem playing aiff sounds with the Preferences, Sounds app and MediaPlayer. If I play them with VLC there is no problem. Also I am finding the mouse pointer locking up from the start now, when a aiff sound finishes playing. I will upload one of the aiff sound files.

Changed 11 years ago by cebif

Attachment: BeBeep.aiff added

comment:4 Changed 11 years ago by cebif

I was testing with hrev26181

comment:5 Changed 9 years ago by dlmcpaul

Resolution: fixed
Status: in-progressclosed

I have retested this after the various changes that have been made to buffer media files better and I cannot reproduce any issues.

Note: See TracTickets for help on using tickets.