Opened 3 years ago

Closed 4 months ago

#12807 closed bug (invalid)

WebPositive Crashes; core files attached

Reported by: MichaelCrawford Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Facebook, Soylent News, git Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

the crashes happen only occasionally.

The first one I was running a VM with only 512 MB of memory. I visited http://soylentnews.org/. At the top of the window was printed:

302 Moved Permanently nginx

then below that the Soylent News homepage was rendered correctly. WebPositive crashed immediately after that.

The second crash my VM had 4 GB. I had Soylent News open in my first tab and Facebook in my second. The crash happened a while after opening FaceBook, but I'm afraid I don't recall what I was doing when the crash occurred.

In both cases, I had git running a full anonymous checkout of the Haiku source code. A possible problem may be that git uses a lot of memory when checking out large codebases; perhaps WebPositive fails to check for a NULL returned from malloc. (In C++, that should throw an exception.)

Nightly gcc2 hybrid 50336.

Change History (6)

comment:1 Changed 3 years ago by MichaelCrawford

Both core files are far too large to attach, even when compressed with bzip2. I'll host them on my own site then post their links here.

comment:2 Changed 3 years ago by pulkomandy

for the record, the WebKit code is built with -fno-exceptions as exceptions would interact badly with some low level code (I think the javascript interpreter).

Regarding core files: it would be nice to have both the text report and the core file if possible (the text report is handy for quickly looking at the backtrace and seeing if it's a duplicate of some other ticket). Opening core files requires running Haiku, which I'm not at the moment (at work).

comment:3 Changed 3 years ago by MichaelCrawford

I'm having some trouble uploading the core files to my server. scp stalls after a few megabytes, and webpositive crashes when attempting to upload to google drive. Maybe dropbox will work.

comment:4 Changed 3 years ago by pulkomandy

I would suggest netcat as a simple way to copy files to a server. Or FTP, or rsync. Or, you can run PoorMan to share the files from the Haiku machine with HTTP and download them from elsewhere.

As far as I know, dropbox is currently not working in Web+ (crashes in WebSocket), nor in Qupzilla (won't login, says browser is too old).

comment:5 Changed 2 years ago by waddlesplash

Component: - GeneralApplications/WebPositive
Keywords: WebPositive removed
Owner: changed from nobody to pulkomandy

comment:6 Changed 4 months ago by waddlesplash

Resolution: invalid
Status: newclosed

No reports or core files, and site doesn't crash here.

Note: See TracTickets for help on using tickets.