Opened 2 years ago

Closed 2 months ago

#12848 closed bug (fixed)

VirtualMemory crashes on exit if volume is read-only

Reported by: IIsi50MHz Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Preferences/VirtualMemory Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Test:

  • Boot Haiku from CD or other read-only media.
  • Open VirtualMemory preflet; it is not necessary to change any setting.
  • Close VirtualMemory.

Result: VirtualMemory crashes with segment violation in SettingsWindow::_RecordChoices()

Resolution: VirtualMemory should not attempt to save settings to read-only media. Probably, it should inform the user that virtual memory cannot be used because the boot volume is read-only.

Change History (3)

comment:1 Changed 20 months ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:2 Changed 2 months ago by IIsi50MHz

No longer reproducible on hrev52357 when booted from CD-RW. (Haven't tested this in a long time.)

Note 1: There is also no warning when trying to set a virtual memory size greater than zero with the CD-RW as the target. The setting is accepted, but allocated size remains zero bytes. Not necessarily an error, but potentially confusing?

Note 2: There is a warning when trying to disable virtual memory, even when still set to automatic size of zero bytes, which seems silly.

comment:3 Changed 2 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.