Opened 12 years ago

Closed 11 years ago

#1287 closed bug (fixed)

DHCP does not work if there is more than one NIC present.

Reported by: bbjimmy Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/net_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #2414
Has a Patch: no Platform: x86

Description (last modified by axeld)

Run haiku with two NIC cards. even if both have access th DHCP servers neither will obtain an ip or route.

Attachments (4)

one_nic.png (118.3 KB) - added by bbjimmy 12 years ago.
with one nic
two_nics1.png (13.2 KB) - added by bbjimmy 12 years ago.
with two nics
two_nics2.png (12.8 KB) - added by bbjimmy 12 years ago.
the other nic
two_nics3.png (8.9 KB) - added by bbjimmy 12 years ago.
bothe nics

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by bbjimmy

Attachment: one_nic.png added

with one nic

Changed 12 years ago by bbjimmy

Attachment: two_nics1.png added

with two nics

Changed 12 years ago by bbjimmy

Attachment: two_nics2.png added

the other nic

Changed 12 years ago by bbjimmy

Attachment: two_nics3.png added

bothe nics

comment:1 Changed 11 years ago by axeld

Blocking: 2414 added

comment:2 Changed 11 years ago by bbjimmy

As of hrev28415, and probably before, this issue has been resolved. Both NICs receive an ip and gateway. one must delete ( ifconfig --delete ) the default NIC to use the second one, but DHCP does work for both NICs.

Please close this ticket.

comment:3 Changed 11 years ago by axeld

Description: modified (diff)
Resolution: fixed
Status: newclosed

Thanks for the note.

Note: See TracTickets for help on using tickets.