Opened 3 years ago

Closed 2 years ago

#12878 closed bug (duplicate)

HaikuDepot: does not get the newest available version to install

Reported by: lelldorin Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Kits/Package Kit Version: R1/Development
Keywords: Cc:
Blocked By: #12503 Blocking:
Has a Patch: no Platform: All

Description

I have done a upload of my latest version of HPKGCreator (V. 0.8-4) and want to install it from our repository server. But i cant do that, because HaikuDepot says me i should install the old version (V. 0.7-3) from FatElk repository.

Yes, i have set the server for searching to "BeSly repository" and then i selct my newest version 0.8.-3 but then i click on install HaikuDepot display the download version from fatelk and not the new version from BeSly repository.

Change History (4)

comment:1 Changed 3 years ago by korli

Sounds like #12503.

comment:2 Changed 3 years ago by bbjimmy

it is indeed a duplicate. It seems we need to re-think ht use of the priority line in the repo.info file for a third party repo. I set the fatelk repo to 1 and have not had this issue, but this does not allow one to download yab from the haikuports repo if the fatelk repo is added to your package repositories.

comment:3 Changed 2 years ago by diver

Cc: Lelldorin removed
Component: - GeneralKits/Package Kit
Keywords: HaikuDepot repository install removed

comment:4 Changed 2 years ago by humdinger

Blocked By: 12503 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.