Opened 3 years ago

Closed 3 months ago

#12888 closed bug (fixed)

Messages through the website's "contact" form seem to go unnoticed

Reported by: Giova84 Owned by: haiku-web
Priority: normal Milestone:
Component: Website/www.haiku-os.org Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Hi, is the second time after years that I attempt to send a message using the following form https://www.haiku-os.org/contact

But I never received a response: I sent messages after visit this page https://www.haiku-os.org/community/links where is stated "If you have a community-based Haiku-related site that you would like us to add to this page, contact us"; well I attempt since years to contact someone :-)

I'd wish add my new website to the community links:

http://softwaredepot.altervista.org/

However, as I stated, I also attempted to use the contact form in past: the first time, IIRC, was three years ago, but no one never replied: then I tried again to use the contact form to report some spam activity on the forum, but again I didn't see any response.

By an administration point of view, the website seems abandoned..

Currently I still see some spam posts in the comment section of the following article https://www.haiku-os.org/blog/barrett/2016-07-15_streaming_support_and_mediakit_development_report_7#comments (the comment from the user zakbut, is a member since 1 day and he post spam links): while spammers (registered as new users) are free to spam the website, in the the meantine regular and long time users are unable to post on the site due the spam filter: ticket:12734

Change History (8)

comment:1 Changed 3 years ago by Giova84

There is another spam comment by the user zakbut:

https://www.haiku-os.org/blog/barrett/2016-07-18_tales_video_editor#comment-34246

Sorry if i report this here, but there is no way, on the haiku website, to report spam and the contact form in facts, doesn't work at all.

comment:2 Changed 3 years ago by humdinger

Summary: [Haiku-os.org website] Seems that no one will check the messages sent using the contact page - and globally the official website has a bad administrationMessages through the website's "contact" form seem to go unnoticed

I deleted those two reported spam posts and banned the user. Spam posts get usually deleted by someone after a few hours, so I'd disagree that the website administration looks abandoned. No idea where the "contact" form ends up though...

Reporting spam in the #haiku IRC channel should be the quickest and easiest way. Or post to the haiku-web mailinglist.

comment:3 Changed 3 years ago by Giova84

I'm sorry, maybe i used the wrong term/intention by saying "the website administration looks abandoned"; obviously wasn't intended as negative criticism :-)

However in past I noticed that spam post were still present also after some days. Refering to ticket:12734 maybe would be a good idea implement the ability to reports spam post, to accelerate the the removal process.

Anyway the next time that I will see some spam post I will follow your suggestion; I'm sorry again but I wasn't aware of the best place where report these spam posts, since the messages sent through the website's "contact" form seem to go unnoticed.

comment:4 Changed 3 years ago by humdinger

No problem, Giovanni. :)
You're of course correct, the website could use more people reporting spam etc. as expressed in ticket:12734. There seems to be an issue with our Drupal being more complex and modul-ridden than necessary. I think waddlesplash and a few others are looking for a way improve things.

Maybe someone can investigate how the contact mails end up in /dev/null before those site-migrations or whatever begin.

comment:5 Changed 3 years ago by umccullough

As of right this moment, there are 5 "contact form" options on the website.

I'm not sure when they were last fiddled with, but it seems they go to the following email addresses:

Donations -> donations@… (i'm pretty sure that gets forward to haiku.inc@…, which are then forwarded to several individuals including myself)

General -> waddlesplash@… (not sure when he set this up)

Haiku Inc. -> contact@… (pretty sure this also gets forwarded to haiku.inc@… where it may or may not be forwarded to others)

Marketing -> waddlesplash@… (again, not sure when he set this up)

Website feedback -> webmaster@…, waddlesplash@… (I'm not sure where webmaster@… goes)

There used to be a "contact@…" email address that was forwarded to several people, but it looks like it's no longer being used... probably when waddlesplash changed things to go to himself.

comment:6 Changed 3 years ago by waddlesplash

But I never received a response:

Yes, I did get your message it appears; however, it looks like you sent it only yesterday (at 9:10 AM on the 27th, my time; it's now 5:30 PM on the 28th, my time). I don't have that much time for Haiku during the week, I usually get to such things on weekends. I can have a look at this then, or someone else with admin access on the site can.

General -> ​waddlesplash@… (not sure when he set this up) Marketing -> ​waddlesplash@… (again, not sure when he set this up)

A few months ago, I believe. I don't recall what it was before -- possibly Niels, or just a black hole, I think? I might've asked him if I could take that over? I don't recall.

Website feedback -> ​webmaster@…, ​waddlesplash@… (I'm not sure where ​webmaster@… goes)

I didn't either, which is why I added myself as a CC, to ensure it didn't get blackholed. Which apparently it was, and I've gotten some legitimate questions to some of those addresses (mostly trivial ones that probably could've been solved by the FAQ, but questions nonetheless...)

There used to be a "​contact@…" email address that was forwarded to several people, but it looks like it's no longer being used... probably when waddlesplash changed things to go to himself.

I think I asked someone where that went, and it was essentially a black hole? I don't know, and nobody else did either when I asked, I think.

Anyway, this is where an internal mailing list would be useful, because mails could be sent to it this way and then any number of people could respond. Changing things to me was intended to be a stopgap, but considering I've only gotten about 1-2 non-spam mails per month about it, it isn't an issue for me to take care of it.

comment:7 Changed 2 years ago by waddlesplash

Component: WebsiteWebsite/www.haiku-os.org
Status: newassigned

component to Website/www.haiku-os.org

comment:8 Changed 3 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

We've been more diligent about responding to these, so I think this is "fixed".

Note: See TracTickets for help on using tickets.