Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1291 closed bug (invalid)

usb support for the Dell D/Port Advanced Port Replicator and Dell Latitude D610 in Zeta 1.5

Reported by: modeenf Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Mouse and Keyboard are not working with the Dell D/Port APR (hrev21591) the USB ports on the D/Port are not activated?

As I have removed Zeta's own USB kit usb_dev_info are probably not working but it reports the same amount of USB that I have with the D/Port and without (D/Port adds 3 usb ports)

$ usb_dev_info --listall USBKit: Driver version 0x0015 != expected version 0x0016 USBKit: Driver version 0x0015 != expected version 0x0016 USBKit: Driver version 0x0015 != expected version 0x0016 USBKit: Driver version 0x0015 != expected version 0x0016 USBKit: Driver version 0x0015 != expected version 0x0016 USBKit: Driver version 0x0015 != expected version 0x0016 USBKit: Driver version 0x0015 != expected version 0x0016 USBKit: Cannot open '/dev/bus/usb/raw': General OS error $ listdev | grep USB PCI bus, device #5: Serial Bus Controller (USB) [c|3|0] PCI bus, device #6: Serial Bus Controller (USB) [c|3|0] PCI bus, device #7: Serial Bus Controller (USB) [c|3|0] PCI bus, device #8: Serial Bus Controller (USB) [c|3|0] PCI bus, device #9: Serial Bus Controller (USB) [c|3|20]

Change History (5)

comment:1 by mmlr, 12 years ago

Resolution: invalid
Status: newclosed

First of all, using the Haiku USB stack on ZETA is not a supported combination. It has not been tested and you will likely make your USB environment worse by using it. As ZETA supports USB 2.0 already there is little point in replacing the stack with the one from Haiku.

From the output you seem to have a version mismatch between the installed usb_raw driver and the USBKit in use. If you use the usb_dev_info from Haiku you need to use the usb_raw from Haiku too. Please follow the steps at http://haiku-os.org/blog/mmlr/2007-04-20/using_the_haiku_usb_stack to replace the usb_raw driver if you really want to keep the Haiku stack.

Then what you list with listdev are the USB controllers. These are built into the device you use. A port replicator usually does not add controllers, it only adds ports through a hub. It is like plugging in a USB hub in one of the USB ports. Therefore you won't see a change in listdev.

Closing this bug as invalid.

comment:2 by mmlr, 12 years ago

Additional comment: You state that mouse/keyboard are not working when using the replicator (hub). This is caused by the fact that these are low or fullspeed (USB 1.1) devices and the hub probably supports USB 2.0. The ehci driver will handle this port and this driver cannot handle any USB 1.1 devices plugged into USB 2.0 hubs as the transaction translator protocol is not implemented.

comment:3 by modeenf, 12 years ago

I replace the USB stack to test it and see how far it hade come. The original Zeta 1.5 USB stack hade the same problems as I reported here.

I havn't tested if usb mass storage driver works but the Zeta 1.5 didn't so I have realy not lost anything but have the chanse of helping Haiku :)

So Haiku has a usb_dev_info app didn't know that. Will have to change the USBKit and build this usb_dev_info.

I didn't change the USBKit.a or .so file as thouse was for apps and not drivers. running the original usb_dev_info was just a test to se what would happend.

I will investigate to see what version of USB there are in D/Port or does it exist a app that can list this?.

comment:4 by modeenf, 12 years ago

From dell: "four 4-pin, USB 2.0-compliant connectors: three standard USB and one powered USB" http://support.euro.dell.com/support/edocs/acc/dapr/en/7u874eb1.htm#1132497

so look's like this transaction translator protocol for usb 1.1 to usb 2.0 are needed. enhancement perhaps?

comment:5 by mmlr, 12 years ago

You can check if they are hubs using the device entries exported by usb_raw. Run "ls -laR /dev/bus/usb" with and without the replicator and compare the listing. You should see something like "/dev/bus/usb/0/0/hub" when it is a hub that is connected. You can also verify if the devices plugged into a hub work by using this method. The entries are then numbered according to the port they are plugged into.

Note: See TracTickets for help on using tickets.