Opened 3 years ago

Closed 3 years ago

#12912 closed bug (fixed)

undefined reference for _setjmp

Reported by: KapiX Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: System/libroot.so Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I am trying to compile Embeddable Common Lisp [1], but _setjmp is not defined in libroot. setjmp works fine so I am using a workaround for now: #define _setjmp setjmp

hrev50467 gcc4h

[1] https://gitlab.com/embeddable-common-lisp/ecl

Change History (2)

comment:1 Changed 3 years ago by KapiX

The problem is not in ECL: it checks whether _longjmp is defined and then uses proper functions. Problem is _longjmp is in libroot and _setjmp is not.

comment:2 Changed 3 years ago by pulkomandy

Resolution: fixed
Status: newclosed

Fixed in hrev50488.

Note: See TracTickets for help on using tickets.