Opened 3 years ago

Closed 3 years ago

#12924 closed bug (no change required)

xdg_basedirs.sh not sourced

Reported by: miqlas Owned by: axeld
Priority: blocker Milestone: R1/beta1
Component: Servers/launch_daemon Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It isn't sourced anymore and so the XDG environmental variables doesn1t set as start.

It should sourced from ~/config/settings/boot/UserSetupEnvironment, right?

Change History (3)

comment:1 by waddlesplash, 3 years ago

Component: System/POSIXServers/launch_daemon
Milestone: UnscheduledR1/beta1
Owner: changed from nobody to axeld
Priority: normalblocker

assuming launch_daemon regression, making B1 blocker

comment:2 by pulkomandy, 3 years ago

It is sourced from /data/etc/profile, and that works properly here.

/Donnees/Dev/Haiku/haiku$ env |grep XDG
XDG_DATA_HOME=/boot/home/config/non-packaged/data
XDG_CONFIG_DIRS=/boot/system/settings
XDG_CONFIG_HOME=/boot/home/config/settings
XDG_CACHE_HOME=/boot/home/config/cache
XDG_DATA_DIRS=/boot/system/non-packaged/data:/boot/system/data

What's your setup? Is your shell properly sourcing /data/etc/profile? Are you using plain bash or some other thing?

comment:3 by pulkomandy, 3 years ago

Resolution: no change required
Status: newclosed

After investigation on miqlas machine, it turns out he is using zsh (or fish?) and that is probably the cause for his problem. This will have to be fixed on the shell used. Our bash is fine.

Note: See TracTickets for help on using tickets.