Opened 3 years ago

Closed 3 years ago

#12974 closed bug (duplicate)

WebPositive unresponsive - hrev50549

Reported by: DFergFLA Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #11879 Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

When I go to www.msn.com the page loads fine, but clicking on any link to an article results in WebPositive becoming unresponsive. At this point I have no choice but to kill the application. I can reliably reproduce the issues. It doesn't crash, so I am not getting any kind of crash report to attach.

Change History (3)

comment:1 by diver, 3 years ago

Component: ApplicationsApplications/WebPositive
Description: modified (diff)
Owner: changed from nobody to pulkomandy
Summary: WebPositve unresponsive - hrev50549WebPositive unresponsive - hrev50549

comment:2 by AlienSoldier, 3 years ago

Look similar to my problem. https://dev.haiku-os.org/ticket/11879 Can you still natigate tab when this happen? I isolate my problem mainly to one site i use for work (can't link it as it is behind a password).

comment:3 by pulkomandy, 3 years ago

Blocked By: 11879 added
Resolution: duplicate
Status: newclosed

This is quite easy to reproduce anyway, on various websites.

The problem is that we try to stop an HTTP request, and wait forever for it to stop. There were some attempts to mitigate the issue in the code but it doesn't work reliably. Fixing this properly may need yet another redesign of the HTTP library.

Note: See TracTickets for help on using tickets.