Opened 12 years ago

Closed 7 years ago

#1299 closed bug (fixed)

messed up screen with intel_extreme driver

Reported by: modeenf Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have a Dell Latitude x300 with intel_extreme g-card but the LCD are all messed up

this driver are running on Zeta 1.21 and the driver are from r21xxx x300_intel_extrem_desctop.jpg this are how a print screen looks like x300_intel_extrem_screen.jpg this are I see the screen (LCD).

Attachments (9)

syslog_intel_extrem_r21xxx (50.0 KB) - added by modeenf 12 years ago.
this are a syslog and the driver are from hrev21634
intel_extrem_855GM_screen.jpg (18.5 KB) - added by atomozero 12 years ago.
whit my intel 855GM
x300_intel_extrem_desctop.jpg (46.7 KB) - added by modeenf 12 years ago.
my images didn't work, this are new ones
x300_intel_extrem_.zip (175.6 KB) - added by modeenf 12 years ago.
Can't get the images to show right, these are the same but zipt
intel_extrem_R21910 (89.4 KB) - added by modeenf 12 years ago.
from R21910
intel_extrem_R21910.jpg (89.4 KB) - added by modeenf 12 years ago.
other system must have .jpg
intel_extrem_855GM 1 r25994.jpg (39.9 KB) - added by atomozero 11 years ago.
intel_extrem_855GM 2 r25994.jpg (31.2 KB) - added by atomozero 11 years ago.
intel_extrem_855GM r25994.jpg (24.3 KB) - added by atomozero 11 years ago.

Download all attachments as: .zip

Change History (22)

comment:1 Changed 12 years ago by modeenf

it's hrev21632

comment:2 Changed 12 years ago by modeenf

oh and it's a 855GM

I have begune a list of dells (as I have many) at wikipedia. http://en.wikipedia.org/wiki/Dell_Latitude

Changed 12 years ago by modeenf

Attachment: syslog_intel_extrem_r21xxx added

this are a syslog and the driver are from hrev21634

comment:3 Changed 12 years ago by modeenf

I hade a mail conversation with Philippe Houdoin and he pointed to that the problem could be PPL(what now that is)

"considering the framebuffer content looks correct, means that the PLL setup is quite screwed. :-) "

Changed 12 years ago by atomozero

whit my intel 855GM

Changed 12 years ago by modeenf

my images didn't work, this are new ones

Changed 12 years ago by modeenf

Attachment: x300_intel_extrem_.zip added

Can't get the images to show right, these are the same but zipt

comment:4 Changed 12 years ago by modeenf

Some how it's working better in rev 21910

But mouse don't show and I can only see upper part of the screen, the rest are black. Can't see the deskbar. Like if you have the screen at 1024*768 and the desktop at 800*600 and the desktop don't stretch over the rest of the screen.

Have an image but as usually the print screen shows right but the mouse are not shown. Will try to attach.

Changed 12 years ago by modeenf

Attachment: intel_extrem_R21910 added

from R21910

Changed 12 years ago by modeenf

Attachment: intel_extrem_R21910.jpg added

other system must have .jpg

comment:5 Changed 12 years ago by modeenf

External screen are working as it should but still no mouse (rev 21910)

comment:6 Changed 11 years ago by scottmc

Can this one be closed? anyone with an 855 that can verify that it is working ok now? I can verify that a 845 is working fine.

comment:7 in reply to:  6 Changed 11 years ago by modeenf

Replying to scottmc:

Can this one be closed? anyone with an 855 that can verify that it is working ok now? I can verify that a 845 is working fine.

855 still don't work I will test again this weekend but last week the problem still existed, but otherwise haiku are running really good on x300. Hopefully I will attend at next Begister so I can bring my laptop :)

comment:8 Changed 11 years ago by umccullough

845 is working for me on this laptop (Dell Inspiron 1100).

865 is crashing for me now in the accelerant - will log a separate issue soon (haven't had time).

comment:9 Changed 11 years ago by atomozero

I still have the same problem :( hrev25709

comment:10 Changed 11 years ago by axeld

Thanks to luroh, I now have an i945 based laptop so that I am able to look into this over the next weeks.

Changed 11 years ago by atomozero

Changed 11 years ago by atomozero

Changed 11 years ago by atomozero

comment:11 Changed 11 years ago by atomozero

whit hrev25994 the video driver works but i have a litle defect on top of screen and when change the resolution

comment:12 Changed 9 years ago by pulkomandy

Apparently this is still a problem in hrev35402. A friend of mine can make some tests if needed.

comment:13 Changed 7 years ago by kallisti5

Resolution: fixed
Status: newclosed

This is very likely fixed with all the recent Intel extreme work.

Closing for now. If it is still an issue please test, grab syslogs, and ping us to re-open this trac.

Note: See TracTickets for help on using tickets.