Opened 3 years ago

Closed 3 years ago

#13007 closed bug (no change required)

Haiku doesn't recognize partitions on a separate SATA drive

Reported by: Yowane_Haku Owned by: nobody
Priority: normal Milestone: R1/beta1
Component: Partitioning Systems/Intel Version: R1/Development
Keywords: MBR, SATA, HDD Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I have Haiku installed on SATA SSD (258.5 GB) and Windows 10 on SATA HDD (698.6 GB). Both disks are initialized under MBR and have a valid partitioning scheme on them. However, Haiku sees HDD as a GPT disk and doesn't recognize any partitions on it. The same is valid for Haiku booted from live USB. Currently I am using hrev50595. When I connect that HDD via USB port, all partitions are seen and mounted properly.

Attachments (4)

haiku_drive_setup.png (103.6 KB ) - added by Yowane_Haku 3 years ago.
windows_disk_management.png (48.6 KB ) - added by Yowane_Haku 3 years ago.
syslog_non-working (150.5 KB ) - added by Yowane_Haku 3 years ago.
Syslog when the HDD is connected via SATA
syslog_working (397.8 KB ) - added by Yowane_Haku 3 years ago.
Syslog when the HDD is connected via USB

Download all attachments as: .zip

Change History (9)

by Yowane_Haku, 3 years ago

Attachment: haiku_drive_setup.png added

by Yowane_Haku, 3 years ago

Attachment: windows_disk_management.png added

comment:1 by pulkomandy, 3 years ago

Please include a syslog (you can find it in /var/log/syslog) for both working and non-working cases.

If your disk has a GPT on it, then it was later erased with MBR, there may be leftovers of the GPT entries which fool our detection logic. In that case, it would be useful to know how you created the MBR and partitions.

by Yowane_Haku, 3 years ago

Attachment: syslog_non-working added

Syslog when the HDD is connected via SATA

by Yowane_Haku, 3 years ago

Attachment: syslog_working added

Syslog when the HDD is connected via USB

comment:2 by Yowane_Haku, 3 years ago

It might be so that there was GUID before (frankly speaking, I don't remember already).

When I was installing Windows on it, I removed all the existing partitions (including the hidden ones) and initialized the MBR scheme under Windows Installer's drive setup.

I tried doing bootrec /fixmbr from Windows Recovery, but it doesn't seem to help in any way. The SATA controller is working in AHCI mode, but in the Compatibility mode situation is the same.

If the issue is not related to SATA controller, is there any way to fix my MBR without wiping the disk?

Thank you.

comment:3 by pulkomandy, 3 years ago

If you rewrote only the MBR, it may leave parts of the GPT as I mentionned. These are stored at the start and end of the disk. If that's the case, erasing the last 32 and first 34 sectors of the disk (except sector 0 where the MBR is).

https://en.wikipedia.org/wiki/GUID_Partition_Table#/media/File:GUID_Partition_Table_Scheme.svg

You can check with DriveSetup if what's there looks like GPT data (you would see the "EFI PART" marker, for example). Make sure to backup before erasing things.

comment:4 by Yowane_Haku, 3 years ago

Got it. Yes, I checked with DiskProbe and it has EFI PART marker. Thank you =)

The ticket can be closed now.

comment:5 by pulkomandy, 3 years ago

Resolution: no change required
Status: newclosed
Note: See TracTickets for help on using tickets.