Opened 4 years ago

Closed 5 months ago

Last modified 6 weeks ago

#13067 closed bug (fixed)

Bookmark bar drawing error on resize

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: R1/beta2
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc: X512
Blocked By: Blocking:
Platform: All

Description

This is hrev50675.

When the Bookmark bar is showing, making the Web+ window wider leaves drawing artefacts:

drawing artefacts on window resize

Attachments (1)

Bookmark_bar_drawing.png (5.0 KB ) - added by humdinger 4 years ago.
drawing artefacts on window resize

Download all attachments as: .zip

Change History (13)

by humdinger, 4 years ago

Attachment: Bookmark_bar_drawing.png added

drawing artefacts on window resize

comment:1 by pulkomandy, 4 years ago

This is a bug in BMenuBar and the way it is invalidated (you can see some issues inthe main menu bar as well, including in your screenshot). There is already a bug for it somewhere.

comment:2 by humdinger, 4 years ago

Blocked By: 8895 added
Resolution: duplicate
Status: newclosed

Indeed, it's #8895. Reported by me and assigned to you. :)

comment:3 by diver, 5 months ago

Resolution: duplicate
Status: closedreopened

Turns out this is a separate problem after all. While the patch from #8895 fixes menubar drawing errors Bookmark bar still leaves drawing artefacts.

comment:4 by diver, 5 months ago

Cc: X512 added

comment:5 by X512, 5 months ago

I cant't enable bookmark bar. "View"->"Show bookmark bar" has no effect. Adding Shortcuts to bookmarks folder or restarting WebPositive has no effect. Tested on Haiku hrev53699 x86 gcc2hybrid.

comment:6 by diver, 5 months ago

Create a folder here "/boot/home/config/settings/WebPositive/Bookmarks/Bookmark bar" and it should show up.

in reply to:  6 comment:7 by X512, 5 months ago

Replying to diver:

Create a folder here "/boot/home/config/settings/WebPositive/Bookmarks/Bookmark bar" and it should show up.

I added some bookmarks in that folder, but bookmark bar is still not visible. Menu command has no effect.

comment:8 by X512, 5 months ago

I deleted settings files and now bookmarks bar is working.

comment:9 by X512, 5 months ago

Bug is confirmed.

comment:11 by waddlesplash, 5 months ago

Blocked By: 8895 removed
Resolution: fixed
Status: reopenedclosed

Fix merged in hrev53705. Thanks!

comment:12 by nielx, 6 weeks ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.