Opened 3 years ago

Closed 3 years ago

#13072 closed bug (invalid)

Large X screen resolution results in screen scanline artefacts

Reported by: arfonzo Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Graphics/VESA Version: R1/Development
Keywords: Cc: arfonzo
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tested in virtualbox by jessicah and myself with similar result, VESA.

Symptoms:

  • Smaller windows and objects (icons, cursor, menus, widgets): it seems that moving them towards the centre of the screen causes the display issues to appear.
  • Larger windows/objects (background image), seem fine.
  • Also shows during boot progress icons.

Reproduction:

  • Have a 4K-based X-screen resolution: i.e., 3840x1080, 3840x2160.
  • Not yet tested on physical hardware, can someone help us here?

Attachments (1)

haiku-4K-artefacts-01.jpg (1.0 MB ) - added by arfonzo 3 years ago.
Screenshot showing symptoms

Download all attachments as: .zip

Change History (2)

by arfonzo, 3 years ago

Attachment: haiku-4K-artefacts-01.jpg added

Screenshot showing symptoms

comment:1 by axeld, 3 years ago

Resolution: invalid
Status: newclosed

Since the problems go away when triggering a redraw of the VirtualBox window on the host (confirmed via IRC), it's not Haiku's fault, and should be filed at VirtualBox instead.

Note: See TracTickets for help on using tickets.