Opened 2 years ago

Closed 21 months ago

#13098 closed bug (fixed)

64 bit: Text not visible in Print Preview

Reported by: vidrep Owned by: phoudoin
Priority: normal Milestone: Unscheduled
Component: Printing Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

hrev50714 x86_64 Epson NX625 Gutenprint Printer Drivers I configured my printer and selected "Show preview before printing" in the "Printjob Setup" dialog. When printing a text document there is now no visible text in the preview window. This feature was working previously some number of weeks ago. Otherwise, the document prints normally.

Attachments (2)

Print Preview.png (65.6 KB) - added by vidrep 2 years ago.
screenshot1.png (46.1 KB) - added by vidrep 2 years ago.

Download all attachments as: .zip

Change History (15)

Changed 2 years ago by vidrep

Attachment: Print Preview.png added

comment:1 Changed 2 years ago by vidrep

I will try to ascertain in which hrev the regression occurred. Possibly with the update to freetype 2.7 and noto fonts???

comment:2 Changed 2 years ago by vidrep

I tested as far back as hrev50180 x86_64 and found that the issue was already there even at that time. This also appears to be a 64-bit-only issue - x86_gcc2 is not affected by this bug.

comment:3 Changed 2 years ago by vidrep

Platform: Allx86-64
Summary: Text not visible in Print PreviewText not visible in Print Preview (only 64 bit)

comment:4 Changed 2 years ago by vidrep

Summary: Text not visible in Print Preview (only 64 bit)64 bit: Text not visible in Print Preview

comment:5 Changed 2 years ago by phoudoin

That's with the Gutenprint builtin preview window, right? Does it show also with the system Preview pseudo printer driver too?

Looks like a coordinates miscalculation to me.

comment:6 Changed 2 years ago by vidrep

Setting up Haiku Printer Preferences to use the "Preview" printer (screenshot1.png) results in the same blank preview window as when using a real hardware printer.

Changed 2 years ago by vidrep

Attachment: screenshot1.png added

comment:7 Changed 2 years ago by phoudoin

So it's an issue in BPicture replay

comment:8 Changed 2 years ago by vidrep

I'm available to help in any way for printer related issues. You can usually find me on IRC. I have 2 Canon, 2 Epson, 2 HP and 1 Brother multifunction units for testing.

comment:9 Changed 2 years ago by vidrep

This is still an issue with hrev51154. It would be nice to get this sorted out before a Beta release, especially if 64 bit will be an "officially supported" release. I'm ready and willing to put whatever time and effort is required to test any forthcoming fixes.

comment:10 Changed 23 months ago by vidrep

The preview is also missing on 64 bit when scanning a document using Sanity.

comment:11 Changed 21 months ago by korli

Is it the same with hrev51326?

comment:12 Changed 21 months ago by vidrep

hrev51328 x86_64

Preview is now working for both printing and scanning of documents. Thank You!

comment:13 Changed 21 months ago by korli

Resolution: fixed
Status: newclosed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.