Opened 2 years ago

Closed 22 months ago

#13156 closed bug (fixed)

64 bit fails to play some audio and video files

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Audio & Video/Codecs Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev50830 x86_64 This is meant as a test for the recent AVFormatReader commits. I have attached a Sample.mp3 and Sample.AVI that both fail to play. A have also attached the terminal output for each file using both "playfile" and "MediaPlayer". "Sample.AVI" failed on both playfile and MediaPlayer "Sample.mp3" did play using playfile, but failed on "MediaPlayer".

Attachments (3)

Sample.AVI (1.8 MB) - added by vidrep 2 years ago.
Sample.mp3 (1.3 MB) - added by vidrep 2 years ago.
Sample_Terminal.txt (1.1 KB) - added by vidrep 2 years ago.

Change History (7)

Changed 2 years ago by vidrep

Attachment: Sample.AVI added

Changed 2 years ago by vidrep

Attachment: Sample.mp3 added

Changed 2 years ago by vidrep

Attachment: Sample_Terminal.txt added

comment:1 Changed 2 years ago by vidrep

x86_64 played every other audio/video format I tried, including AVCHD (MTS/m2ts), DVD (VOB), and even 4K UHD MP4.

comment:2 Changed 2 years ago by bruno

there is a lot of change done by Dario I think... On x86 lots of files like mp4 wont play here too... Maybe we have to wait only for final changes Dario is going to do I hope...

comment:3 Changed 22 months ago by vidrep

hrev51295 x86_64

Sample.AVI now plays

Sample.mp3 still not playing

comment:4 Changed 22 months ago by korli

Resolution: fixed
Status: newclosed

Fixed Sample.mp3 playing in hrev51306.

Note: See TracTickets for help on using tickets.