Opened 3 years ago

Closed 3 years ago

#13250 closed bug (fixed)

No activation link received for new account at forums

Reported by: kev Owned by: kallisti5
Priority: high Milestone:
Component: Website/Forums Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I'm trying to sign up as Kev-2 because I lost my account creds for Kev and the associated e-mail.

I put my current e-mail account in (a gmail account) and waited, but didn't receive a link, so I requested a second one. After 30+ minutes it's not in my inbox or spam box.

Change History (35)

comment:1 Changed 3 years ago by kev

I changed my e-mail on the Trac account here just now and got an e-mail verification immediately. So something is working, just not on the main site forums...

comment:2 Changed 3 years ago by humdinger

I see a "Kev" user. But since you lost that email account, it doesn't matter because I can't change the associated mail address. There's also a Kev-2. I just sent the activation mail. Did that come through?

comment:3 Changed 3 years ago by kev

Dang re: "Kev". Oh well. Nope, that didn't come through either.

comment:4 Changed 3 years ago by humdinger

Send me a mail to humdingerb at gmail . If your sender matches the account used to register Kev-2 I can try to activate the account.

comment:5 Changed 3 years ago by kev

Sent :)

comment:6 Changed 3 years ago by kev

OK so my account's good now...but I wonder if something is blocking activation e-mails in general?

comment:7 Changed 3 years ago by humdinger

OK. Leaving the ticket open for kallisti5 or others admins to have a look.

comment:8 Changed 3 years ago by humdinger

Summary: No activation link received for new account on main siteNo activation link received for new account at forums

comment:9 Changed 3 years ago by waddlesplash

The email service on the Discourse server was out until a few days ago. kallisti5 fixed it then, so it should be working.

Also, @Kev, it looks like I have the power to change your email on the forums, so I changed it to your Trac one -- I had to add a "+haiku" to it because you were already using it. (I then rejected the post from your Kev-2 account, so there's no duplicates -- feel free to re-create that once you get running on your new account.) So, you should be able to delete "Kev-2" now.

Let me know if you have any other problems...

comment:10 Changed 3 years ago by kev

The email service on the Discourse server appears to not work, at least for me. Thanks for changing my Kev account, but trying to reset the password just now did not send me a link (as with the Kev-2 account until humdinger manually activated it.) Maybe @kallisti5 could check the fix?

I guess since that post is already deleted, I'll delete Kev-2 now.

comment:11 Changed 3 years ago by kev

Kev-2 deleted.

Still getting e-mails fine from Trac here, but not the forums.

comment:12 Changed 3 years ago by kev

I just tried with another, non-gmail address of mine, and it's also not getting an e-mail sent to it. (You can delete the account with username kev-test if you like. I have no way of deleting it until e-mails get fixed.) So it's not gmail-specific either.

comment:13 Changed 3 years ago by waddlesplash

Are you sure? Because I have a Gmail box too and I got Discourse email this morning and right after I changed your account email I sent a test email to my own Gmail address and it got through just fine...

comment:14 Changed 3 years ago by kev

Yes. I still have no Discourse e-mail at my gmail (nor spam) nor at my ibwwg.com account, but have received other e-mails at both since then, so e-mail receiving in general is working fine.

Not sure what to make of that. Anyway I'm not really active anymore, just lurking at the moment, just wanted to post about the launcher I made way back when. Maybe I'll try again later to reset my password but for the discussion for now if you want to throw in a link that's all my intention was.

comment:15 Changed 3 years ago by waddlesplash

Priority: normalhigh
Status: newassigned

OK, I've bumped the priority and deleted that account. Hopefully kallisti5 can take a look into your email problems soon.

comment:16 Changed 3 years ago by kev

OK, thanks...

If it's not just me (and I'd love to know the reason why it would just be me :) ) then this could be a bit of a deterrent to newcomers.

comment:17 in reply to:  9 Changed 3 years ago by kev

Replying to waddlesplash:

Also, @Kev, it looks like I have the power to change your email on the forums, so I changed it to your Trac one -- I had to add a "+haiku" to it because you were already using it. (I then rejected the post from your Kev-2 account, so there's no duplicates -- feel free to re-create that once you get running on your new account.) So, you should be able to delete "Kev-2" now.

I tried just now resetting Kev. Still no e-mail. So I tried resetting the address I sent you. It says, "No account matches [that address]." This made sense when I remembered the +haiku part. So I tried that, but it still says, "No account matches [me+haiku@…]." Based on that I'm not sure your change actually took, unless I didn't understand what you meant by adding "+haiku" to it.

comment:18 Changed 3 years ago by kev

I made two new accounts, both of which you can delete.

Kev2 is at the address I sent you (again) just to try the confirmation e-mail. No e-mail came in (despite the web site success message.)

Kev3 is with +haiku. It shouldn't have let me create this if Kev was set to that. But it did. But no e-mail came in (despite the web site success message.)

I then sent a normal e-mail to +haiku, and it came through immediately. So the address works in general.

I have also checked my spam box, which I had recently cleared, and there is nothing haiku-related in there.

comment:19 Changed 3 years ago by kev

Just got three e-mails:

  1. to me+haiku, [Haiku Community] Confirm your new email address
  2. to me+haiku, [Haiku Community] Confirm your new account
  3. to me, [Haiku Community] Confirm your new account

I'd like without the +haiku so I'm going to try option 3, let's see :)

Last edited 3 years ago by kev (previous) (diff)

comment:20 Changed 3 years ago by kev

The link resulted in this page:

502 Bad Gateway

nginx

comment:21 Changed 3 years ago by kev

OK, tried option 1 then (hoping it's from my original Kev account). Result is a page saying:

There was an error changing your email address. Perhaps the address is already in use?

comment:22 Changed 3 years ago by kev

So close. Door number 2 gave me a page saying, "Welcome...!" with a button to activate my account. Clicking *that* button then gave me a page saying:

Sorry, this account confirmation link is no longer valid. Perhaps your account is already active?

Last edited 3 years ago by kev (previous) (diff)

comment:23 Changed 3 years ago by kev

Could someone manually delete my Kev2 and Kev3 accounts?

comment:24 Changed 3 years ago by kev

Tried to reset the password on Kev twice just now. No e-mails again...

comment:25 Changed 3 years ago by kallisti5

triple check your @brantaero.com email (and your spam folders, Haiku ML folders, etc) I know it's working now. Multiple people have confirmed. Two of the SideKiq queues weren't running.

comment:26 in reply to:  20 Changed 3 years ago by kallisti5

Replying to kev:

The link resulted in this page:

502 Bad Gateway

nginx

That was me fixing the issue :-)

comment:27 Changed 3 years ago by kev

@kallisti5 as I said in the OP I don't have account creds for that address anymore.

I'll try that option 3 again, hopefully that will kick out my unusable address and give me Kev at my current address.

comment:28 Changed 3 years ago by kev

Nope it still says it's in use. I think if someone deleted Kev2 and Kev3 then I should be able to use that link and all would be in order.

comment:29 Changed 3 years ago by waddlesplash

Done.

comment:30 Changed 3 years ago by kev

Still saying, "There was an error changing your email address. Perhaps the address is already in use?" :(

comment:31 Changed 3 years ago by kallisti5

kev: I can update your current email and search for other users using it... could you provide your new email? (maybe obscured so bots don't pick it up)

comment:32 Changed 3 years ago by kev

Thanks but I thought waddlesplash already did? https://dev.haiku-os.org/ticket/13250#comment:9 Anyway it's a gmail one, my username plus 'injamesfield'.

comment:33 Changed 3 years ago by kallisti5

I updated your 'kev' account to that new email. You should of gotten a new confirm email.

comment:34 Changed 3 years ago by kev

Hooray! Everything works. Thank you for fixing it.

comment:35 Changed 3 years ago by kallisti5

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.