Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13318 closed bug (duplicate)

Old package activation states delay bootup

Reported by: jua Owned by: axeld
Priority: normal Milestone: Unscheduled
Component: System/Boot Loader Version: R1/Development
Keywords: Cc:
Blocked By: #12498 Blocking:
Has a Patch: no Platform: All

Description (last modified by jua)

I recently noticed that booting Haiku had become a lot slower for me than it used to be, and the delay was happening in the early boot process, i.e. even before the boot screen icons appear. The boot would be delayed by 10-20 seconds, during which the HDD light was continuously on.

Now I found the reason why: in /boot/system/packages/administrative I had accumulated >250 package activation state directories. The delay in early bootup was caused by the boot loader going through all these package states. After removing them, the bootup is now fast again.

Since these activation states accumulate over time, we should...

  • Either add automatic cleanup of old states (or if there already is something like that, it needs improvement)
  • Or improve efficiency of the boot loader reading the state directories
  • Or both of the above :-)

Attachments (1)

FilWip.png (103.2 KB ) - added by vidrep 3 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 by jua, 3 years ago

Description: modified (diff)

comment:2 by vidrep, 3 years ago

There is also a Haiku clean-up program in Depot, called FilWip, which many seem unaware of. (see attached screenshot)

by vidrep, 3 years ago

Attachment: FilWip.png added

comment:3 by humdinger, 3 years ago

Blocked By: 12498 added
Resolution: duplicate
Status: newclosed

comment:4 by axeld, 3 years ago

Automatically cleaning the system state isn't that easy actually, as it's only an incremental state, ie. it might need previous states to be complete.

Deleting them all is simple of course, but for an automatic solution, one should be smarter than that (like keeping the states of the last two weeks by default). I guess the package kit could help with that, though.

Note: See TracTickets for help on using tickets.