Opened 2 years ago

Closed 9 months ago

#13346 closed bug (not reproducible)

cannot restart media server

Reported by: bruno Owned by: Barrett
Priority: normal Milestone: Unscheduled
Component: Add-Ons/Media/Mixer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Problems occured since hrev50970 now I updated to 50973 and the problem is still there. cannot restart the media server. It will crash again and again.

Attachments (2)

media_addon_server-20562-debug-24-02-2017-20-32-07.report (16.1 KB) - added by bruno 2 years ago.
after blacklisting firewire (15.4 KB) - added by bruno 2 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 2 years ago by diver

Component: - GeneralAdd-Ons/Media/Mixer
Owner: changed from nobody to Barrett

comment:2 Changed 2 years ago by bruno

even by blacklisting the firewire fw_raw file with: https://www.haiku-os.org/guides/daily-tasks/blacklist-packages/ the media add-on server still crashes... Would be good to have someone investigating this old problem. I am sure it was befor Barrets changes there as well. Let have Barret do some paid work again to fix all this problems!

Changed 2 years ago by bruno

Attachment: after blacklisting firewire added

comment:3 Changed 2 years ago by Barrett

Do you have some additional addon installed?

comment:4 Changed 2 years ago by bruno

No not at all as I remember... last I installed haikuporter and did some tests with compileing: artpaint edgar godot_x86 (which does not work)

comment:5 Changed 2 years ago by Barrett

It looks like there's some other problem which has been introduced or exposed by some recent change. I'd suggest the following

  • Test on a clean build.
  • Confirm the revision range you mentioned at the ticket start by retesting both revs, please go back hrev50970 and see if you can find the hrev introducing it.

comment:6 Changed 2 years ago by bruno

even if I go back to hrev50887 the bug is still there... If I go back the changes to the system will be made but not to the user system... so I cannot find the wrong hrev... I started Haiku hrev50887 from the other partition... and there is no bug! But I am afraid to update there... since I can still try to install to the other partition from this partition...

comment:7 Changed 2 years ago by bruno

So if ther is a problem I cannot solve it within the problem Haiku install. Thats a pitty... horror as this happened so often and the only resulution was to do a clean new install... and install and configure everything again.. Thats really a downpoint in using Haiku and or Haikus PKGmanager

comment:8 Changed 2 years ago by bruno

I just overwrote my user install with an older one from another partition... so I dont know what was going wrong... now I got it to work again... dont know what cause this problem... can be closed... until next time...

comment:9 Changed 9 months ago by bruno

please close this ticket...

works now!

comment:10 Changed 9 months ago by diver

Resolution: not reproducible
Status: newclosed

It was probably corrupted mixer settings file.

Note: See TracTickets for help on using tickets.