Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1336 closed bug (fixed)

System lock up, playing WMV9 codec in VLC

Reported by: kvdman Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Audio & Video Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Playing any video WM9 video stream in VLC seems to lock the system. i.e try this stream:

http://www.clubloreley.org/images/stories/videos/rtl.wmv

Attachments (1)

vlc.jpg (124.1 KB) - added by kvdman 12 years ago.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by kvdman

Attachment: vlc.jpg added

comment:1 Changed 12 years ago by aldeck

Works great here under vmware (no sound) with hrev21836, vlc-0.8.6c-BeOS

It played fine for several minutes, low cpu usage, no mem leak. Will test later on real hardware.

comment:2 Changed 12 years ago by kvdman

Yes, seems to work fine now. Although no video, it doesn't lock anymore.

Please close this.

comment:3 in reply to:  2 Changed 12 years ago by aldeck

Tested on real hardware, worked for 1 sec, even got sound, but it seems that the network couldn't handle the bandwidth (rtl8139). No lockup or crash though, vlc and haiku are fine.

comment:4 Changed 12 years ago by stippi

Resolution: fixed
Status: newclosed

Ok, closed then. :-)

comment:5 Changed 12 years ago by aldeck

Yep! Retested on real hardware and the timeouts i experienced were due to an overlay problem, it works pretty well in bitmap mode, and with sound too, thanks to mmu_man's oss :-D

Note: See TracTickets for help on using tickets.