Opened 3 years ago

Closed 4 months ago

#13374 closed bug (no change required)

Daylight savings time did not update

Reported by: Duggan Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Applications/Command Line Tools Version: R1/Development
Keywords: dstcheck Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86-64

Description

We were supposed to lose an hour today and my computer's time didn't change. Running x86_64.

Change History (7)

comment:1 by vidrep, 3 years ago

I can confirm the same here. The DST notification pops up, but the time is not correctly synchronized - it has to be done manually. x86_gcc2h is not affected.

comment:2 by diver, 3 years ago

Component: - GeneralApplications/Command Line Tools
Keywords: dstcheck added; clock time removed

comment:3 by korli, 2 years ago

vidrep, i got today the DST notification popup and it did the right thing, that is ask what to do. The behaviour with synchronization online might be wrong though.

comment:4 by pulkomandy, 2 years ago

What I saw here: On my laptop, where the clock is in "UNIX mode": Haiku did change the clock, and I got the popup. On my desktop, where the clock is in "Windows mode" because Haiku shares that machine with Windows: popup, but clock did not change.

This is the expected behavior. The "Windows mode" is broken when there are multiple OS on the same machine, and it results in each of them changing the time, and you end up with a change of 2 (or more) hours. So, in this situation Haiku expects that you boot Windows to change the time.

Now, please check your clock settings on all affected and unaffected machines.

comment:5 by rjzak, 6 months ago

Daylight savings is now in affect, and there wasn't any notification about it. My laptop has been booted into Haiku all weekend, and the hardware clock is set to local time. The time was fixed when I manually synchronized the time with NTP. hrev52979

comment:6 by pulkomandy, 6 months ago

This is the expected behavior. The "Windows mode" is broken when there are multiple OS on the same machine, and it results in each of them changing the time, and you end up with a change of 2 (or more) hours. So, in this situation Haiku expects that you boot Windows to change the time.

If you want this to work, either you let Windows handle time changes, or you set your hardware clock to GMT. The "local time" mode cannot be working when there are multiple OS trying to manage the time, and is there only for people who want to run Windows side by side with Haiku.

comment:7 by waddlesplash, 4 months ago

Resolution: no change required
Status: newclosed
Note: See TracTickets for help on using tickets.