Opened 2 years ago

Closed 2 years ago

#13383 closed bug (fixed)

PANIC after update: calculated irq routing doesn't match bios for PCI 2:0:0

Reported by: KapiX Owned by: tqh
Priority: normal Milestone: Unscheduled
Component: Drivers/ACPI Version: R1/Development
Keywords: Cc: kallisti5
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev51026 gcc5h Samsung NP270E5V-K01

I'm guessing acpica update is responsible.

Attachments (1)

IMG_20170319_182213434.jpg (1.8 MB) - added by KapiX 2 years ago.
stack trace

Download all attachments as: .zip

Change History (12)

Changed 2 years ago by KapiX

Attachment: IMG_20170319_182213434.jpg added

stack trace

comment:1 Changed 2 years ago by KapiX

Has a Patch: set

comment:2 Changed 2 years ago by KapiX

Device 2:0:0 is Network Controller, RTL8101/2/6E if that helps.

comment:3 Changed 2 years ago by waddlesplash

Has a Patch: unset

comment:4 Changed 2 years ago by waddlesplash

Cc: kallisti5 added

comment:6 Changed 2 years ago by tqh

This is a 32 bit build and you have more than 4GB of ram right?

comment:7 Changed 2 years ago by tqh

Fix coming up. So the problem is that 32-bit addressing flag got lost in Haikus ACPICA header. It forces 32-bit addresses for ACPI on 32-bit builds. Otherwise ACPI is allowed to use addresses beyound 4GB which you can have with PAE. We should enable 64-bit addressing everywhere, but until then we need this.

comment:8 Changed 2 years ago by kallisti5

Nice tqh! I only tested 64-bit :-|. Once in, i'll work on getting our fixed up platform header pushed to acpica.

comment:9 Changed 2 years ago by tqh

Should be fixed in hrev51027.

comment:10 Changed 2 years ago by KapiX

Fixed indeed. Thanks!

comment:11 Changed 2 years ago by tqh

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.