Opened 2 years ago

Closed 8 months ago

#13395 closed bug (no change required)

Problems to send attachments & createing ticket about that

Reported by: Morbid Owned by: nielx
Priority: normal Milestone: Unscheduled
Component: Website/Trac Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Get this:

IndexError: pop from empty list

caused by

GET: /attachment/ticket/13377/ or latest GET: /attachment/ticket/13394/

by pressing create new ticket (about this) i get: Request-URI Too Long The requested URL's length exceeds the capacity limit for this server. Apache/2.4.6 (Linux/SUSE) Server at vmdev.haiku-os.org Port 443

a view weeks ago no problems to send tickets. Last one that works was #13204.

Change History (11)

comment:1 Changed 2 years ago by Morbid

Sorry, to send attachments was meant.

comment:2 Changed 2 years ago by diver

Component: - GeneralWebsite/Trac
Owner: changed from nobody to haiku-web

What browser did you use?

comment:3 Changed 2 years ago by Morbid

Mozilla Firefox latest version 52.0.2 (32-Bit)

comment:4 Changed 2 years ago by Morbid

Appears also with WebPositive and MS Edge. Did an update of Firefox to Version 53.0 with the same error message.

Last edited 2 years ago by Morbid (previous) (diff)

comment:5 Changed 2 years ago by Morbid

Got this in the Trac-Faq:

Q: Why do I see IndexError: pop from empty list when trying to add an attachment?

The issue is seen with Genshi 0.6.1 and 0.7 for languages other than English. The issue can be avoided by downgrading to Genshi 0.6.

comment:6 Changed 2 years ago by nielx

Owner: changed from haiku-web to nielx
Status: newassigned

comment:7 Changed 2 years ago by pulkomandy

Well, if that is the case, you can go in https://dev.haiku-os.org/prefs/language and reset your language to "English (US)".

comment:8 Changed 2 years ago by Morbid

Ok! Seems to work with changing the language to English for now. Thanks Pulkomandy/Haiku-Team. But shouldn't it support other languages again? Ticket can be closed, so far.

comment:9 Changed 2 years ago by humdinger

FWIW, I too have issues uploading attachments, though not wot with this error.

Whenever I attach something, I hit the anti-spam captcha. Which doesn't accept my perfectly correct solution[[BR]] I then go back in the browser history to the "attachment-page", reload that page and re-add my attachment. That one goes thru without captcha about 90% of the time...

comment:10 Changed 2 years ago by Morbid

What Humdinger describes occured to me too.

comment:11 Changed 8 months ago by luroh

Resolution: no change required
Status: assignedclosed

Workaround provided in comment 7, closing.

Note: See TracTickets for help on using tickets.