Opened 13 years ago

Closed 10 years ago

#134 closed bug (fixed)

[SoundRecorder] doesn't start

Reported by: diver Owned by: korli
Priority: normal Milestone: R1
Component: Applications/SoundRecorder Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by korli)

Sondrecorder doesn't start if no media_server running with error (Unknows Media Kit Error), althouh R5's Soundrecorder under Haiku without media_server.

Change History (15)

comment:1 Changed 13 years ago by diver

Summary: Sondrecorder doesn't startSoundrecorder doesn't start

comment:2 Changed 13 years ago by diver

Sorry, i mean Soundrecorder.

comment:3 Changed 13 years ago by korli

Resolution: wontfix

comment:4 Changed 13 years ago by korli

This isn't a bug. Current feature set of SoundRecorder makes it impossible to start without a media_server connection. It should however complain with a clear error message "Cannot connect to media server" (tested on R5 with Haiku SoundRecorder).

comment:5 Changed 13 years ago by korli

Status: newclosed

comment:6 Changed 13 years ago by korli

bug_group: developers

comment:7 Changed 12 years ago by diver

Platform: All
Resolution: invalid
Status: closedreopened

Oh, well "Cannot connect to media server" would be nice, please add it. Reopening it for now.

comment:8 Changed 12 years ago by korli

Description: modified (diff)

I tested and with no media server it tells : "Cannot connect to media server : System failure. [80004100]". Don't you get this popup when using SoundRecorder on Haiku ?

comment:9 Changed 12 years ago by diver

Summary: Soundrecorder doesn't startSoundRecorder doesn't start

I get "Cannot connect to media server : General system error. [ffffffff]" which IMHO is not the right error message for the end user. I would like to see "No audio hardware detected" (this is from R5's MediaPlayer i think) or something like that (which will explain why this error) as it's far more informative, and i could guess that my audio card is not detected (no driver). Could you change the error message please, then i would insist on closing this bug! ;-)

comment:10 Changed 11 years ago by nielx

Component: - Applications- Applications/SoundRecorder

Set to the proper component.

comment:11 Changed 11 years ago by diver

Any progress on this? I think this bug could be easy to fix.

comment:12 Changed 11 years ago by modeenf

depends, strerror(int error_code) are used to translate the error. I think that we should fix this on the OS not only on this application, but I don't know if this are a bug anymore as we don't report "Unknows Media Kit Error".

comment:13 Changed 11 years ago by diver

Should i open another bug then?

comment:14 Changed 11 years ago by diver

Summary: SoundRecorder doesn't start[SoundRecorder] doesn't start

comment:15 Changed 10 years ago by korli

Resolution: fixed
Status: reopenedclosed

Fixed in hrev28303

Note: See TracTickets for help on using tickets.