Opened 2 years ago

Closed 2 years ago

Last modified 20 months ago

#13404 closed bug (duplicate)

Regression: text editors and Terminal are no longer able to display Ascii characters

Reported by: Giova84 Owned by: stippi
Priority: normal Milestone: Unscheduled
Component: User Interface Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

hrev51051

I have a text file (the "profile" file, which is used to customize the Terminal's prompt) which contain an ASCII character (the "high voltage" character, this one: " ⚡ " http://www.fileformat.info/info/unicode/char/26a1/index.htm)

Well, when I open this file using Pe text editor, i can no longer see this ASCII character: this happened since I upgraded Haiku (I didn't upgraded Haiku since this summer, IIRC I was running a nightly build from the first days of August), please notice that I set Pe to display the font by using the monospace font called "Inconsolata": on the last nightly build from August, I was able to see this ASCII character using the "Inconsolata" font.

I also use the "Inconsolata" monospace font to display the terminal, and so, this ASCII character is also not displayed here.

If I open this tect file using another text editor, or if i set Pe to display the fonts by using any "DejaVu Sans" font, I can see this Ascii character.

I heard of the fact that some time ago, on Haiku, was changed the default fallback font to "Noto". If i attempt to display this character using Noto, in fact, i'm not able, again, to see this Ascii character.

Attachments (1)

font_compare.png (198.6 KB) - added by Giova84 2 years ago.

Download all attachments as: .zip

Change History (8)

Changed 2 years ago by Giova84

Attachment: font_compare.png added

comment:1 Changed 2 years ago by Giova84

Has a Patch: set

Oops.. Sorry.. I wrongly set "Has a Patch".

Last edited 2 years ago by Giova84 (previous) (diff)

comment:2 Changed 2 years ago by pulkomandy

Has a Patch: unset

comment:3 Changed 2 years ago by humdinger

Blocked By: 13389 added
Resolution: duplicate
Status: newclosed

Looks like another case of non-working fallback to the Noto Symbols font. The character " ⚡ " (miscellaneous symbol 0x26A1) is visible in Pe when DejaVu Mono or Noto Symbols is set, but not when using Noto Mono or Regular. Adding as duplicate to #13389.

comment:4 Changed 2 years ago by Giova84

Blocked By: 13389 removed

(In #13389) As i reported on ticket:13404 I found a similar issue: I'm no longer able to see Ascii characters, by using another font: "Inconsolata". On older nightlies there are no issues. As stated by Humdinger on my ticket:

"Looks like another case of non-working fallback to the Noto Symbols font. The character " ⚡ " (miscellaneous symbol 0x26A1) is visible in Pe when DejaVu Mono or Noto Symbols is set, but not when using Noto Mono or Regular."

comment:5 Changed 2 years ago by Giova84

"Blocked By 13389 removed" .. I didn't removed the "blocked by".. I only report such comment in the other ticket!

comment:6 Changed 2 years ago by humdinger

Blocked By: 13389 added

comment:7 Changed 20 months ago by pulkomandy

Blocked By: 13389 removed
Note: See TracTickets for help on using tickets.