Opened 3 years ago

Closed 3 years ago

#13408 closed bug (no change required)

Package manager, trouble with dependencies ("nothing provides..")

Reported by: Giova84 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Kits/Package Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: x86

Description

Hi, I also reported this issue (while i attempted to install mplayer from HaikuDepot) on GitHub/HaikuPorts, but to be sure I also report this issue here, because maybe could be also related to the package manager/system.

Today (on Haiku hrev51051 gcc2 hybrid) I attempted to install mplayer 1.1.1-3 from HaikuDepot, but i get an error message:

"Nothing provides libpng_x86 16.17.0"

libpng_x86 is installed from HaikuDepot, and everything on my system is updated, but libpng_x86 seems an older version.

Change History (6)

comment:1 by pulkomandy, 3 years ago

The mplayer package needs to be rebuilt to fix this. Such problems will go away when we finally automate the package building process.

comment:2 by Giova84, 3 years ago

Thank you, I wasn't aware of this fact.

However, here, there is the link about the bug of mplayer on Haikuports: https://github.com/haikuports/haikuports/issues/1263

comment:3 by Giova84, 3 years ago

hrev51122 (x86_gcc2hybrid): Today, while I attempted to run pkgman full-sync, I encountered a similar issue:

problem 1: nothing provides lib:libboost_atomic_x86>=1.57.0 needed by libtorrent_rasterbar_x86-1.0.9-1
  solution 1:
    - keep libtorrent_rasterbar_x86-1.0.6-2 from excluded repository

I didn't go forward, to avoid to "break" something. And I also didn't open a ticket on github, since maybe is a similar issue. It is ok?

comment:4 by Giova84, 3 years ago

Sorry for the noise. I noticed that libtorrent_rasterbar_x86-1.0.9-1 is not installed at all on my system, but I have libtorrent_rasterbar_x86-1.0.6-2-x86_gcc2.hpkg instead. So, why pkgman claims about the 1.0.9-1 version? Furthermore libboost_atomic_x86 is not present at all on my system.

comment:5 by pulkomandy, 3 years ago

That's exactly what it is saying:

"the package repo has version 1.0.9, but that one requires libboost_atomic version 1.57, which is not available in the repository. I suggest you keep using version 1.0.6, which will continue to work."

It seems someone updated libtorrent_rasterbar, but did not update libboost which it depends on. This should be fixed once we switch to the automated package build system, which makes sure to have a coherent set of packages. As long as we do things manually, such errors will keep happening.

comment:6 by diver, 3 years ago

Resolution: no change required
Status: newclosed

Not a Haiku bug.

Note: See TracTickets for help on using tickets.