Opened 2 years ago

Closed 11 months ago

#13410 closed bug (fixed)

mp3 file will crash MediaPlayer after seek

Reported by: vidrep Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev51061 x86_gcc2h Sample mp3 attached (VanillaFudge.mp3) Debug report attached Steps to replicate:

  1. Play file
  2. Seek to mid-playback (wait for file to resume playing)
  3. Pause
  4. Resume playback
  5. Stop
  6. Resume playback from start -> crash (or scrambled audio)

Attachments (2)

VanillaFudge.mp3 (1.3 MB) - added by vidrep 2 years ago.
MediaPlayer-1566-debug-02-04-2017-16-15-26.report (22.2 KB) - added by vidrep 2 years ago.

Download all attachments as: .zip

Change History (10)

Changed 2 years ago by vidrep

Attachment: VanillaFudge.mp3 added

comment:1 Changed 2 years ago by vidrep

Has a Patch: set

comment:2 Changed 2 years ago by vidrep

Owner: changed from stippi to pulkomandy
Status: newassigned

comment:3 Changed 2 years ago by pulkomandy

Only gcc2h? Can you check one of the other versions?

comment:4 Changed 2 years ago by vidrep

Tested on x86_gcc5 hybrid. There is no delay on resumption of playback after a seek or pause, as is apparent on x86_gcc2 hybrid. Files do not crash MediaPlayer when following the steps outlined in the ticket description.

Last edited 2 years ago by vidrep (previous) (diff)

comment:5 Changed 2 years ago by pulkomandy

Has a Patch: unset

comment:6 Changed 22 months ago by vidrep

Tested today using hrev51307 x86_gcc2h.

The problem is still there.

comment:7 Changed 11 months ago by waddlesplash

Confirmed that ​https://github.com/haikuports/haikuports/pull/2758 fixes this issue.

comment:8 Changed 11 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Fixed in hrev52057.

Note: See TracTickets for help on using tickets.