Opened 4 years ago

Closed 22 months ago

Last modified 14 months ago

#13413 closed enhancement (duplicate)

Package system: add a notification when a package has been installed

Reported by: Giova84 Owned by: bonefish
Priority: normal Milestone:
Component: Servers/package_daemon Version: R1/Development
Keywords: Cc:
Blocked By: #10881 Blocking:
Platform: x86

Description

I noticed that the package system, has already some notifications, eg when there is an error (I noticed this occurs, eg, when a network connection is not available, when I attempt to install local packages). Another scenario is when we install local packages which requires to download dependencies: eg when I installed QBittorrent it takes a while, since it had to download the QT package and some other dependencies, but would be the same from HaikuDepot. Ok: HaikuDepot will show an "active" word in its window, but is not always noticeable (the user can minimize the window, or check for other packages): an average user could be unaware of this, so a notification of "succesfully installed package" would be nice.

Personally I achieve this by using post-install script in my packages: as an example I rely on this:

export sysapps=$(finddir B_SYSTEM_APPS_DIRECTORY)
notify --type important --group "Package Installation" --title "Done" --icon $sysapps/Installer "Wonderful package successfully installed"

which will result as:

http://funkyimg.com/i/2rhGY.png

Change History (3)

comment:1 by Giova84, 4 years ago

Furthermore wolud be possible use a "progress" notification, for each dependency which is installed.

comment:2 by leavengood, 22 months ago

Blocked By: 10881 added
Resolution: duplicate
Status: newclosed

Duplicate of #10881. I do not plan to do a progress notification, just a final one.

comment:3 by nielx, 14 months ago

Milestone: Unscheduled

Remove milestone for tickets with status = closed and resolution != fixed

Note: See TracTickets for help on using tickets.