Opened 2 years ago

Closed 11 months ago

Last modified 11 months ago

#13415 closed bug (fixed)

Haiku don't load app_server after boot (hrev51061)

Reported by: michaelvoliveira Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: System/Kernel Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: Blocking: #14098
Has a Patch: no Platform: All

Description

Booting from a pendrive

The screen blinks after the rocket icon, then go back to boot screen and KDL.

Using VESA, the app_server freezes on load. Using VESA + Failsafe option, Haiku works.

Using: Radeon R7 360 0x665f Atheros AR9287 0x2e

Attachments (5)

P_20170403_214048.jpg (2.5 MB ) - added by michaelvoliveira 2 years ago.
KDL
P_20170403_214107.jpg (2.3 MB ) - added by michaelvoliveira 2 years ago.
KDL
P_20170403_214119.jpg (2.3 MB ) - added by michaelvoliveira 2 years ago.
KDL
P_20170403_214140.jpg (3.1 MB ) - added by michaelvoliveira 2 years ago.
KDL
P_20170407_135606.jpg (2.0 MB ) - added by michaelvoliveira 2 years ago.
KDL

Change History (21)

by michaelvoliveira, 2 years ago

Attachment: P_20170403_214048.jpg added

KDL

comment:1 by michaelvoliveira, 2 years ago

Has a Patch: set

by michaelvoliveira, 2 years ago

Attachment: P_20170403_214107.jpg added

KDL

by michaelvoliveira, 2 years ago

Attachment: P_20170403_214119.jpg added

KDL

by michaelvoliveira, 2 years ago

Attachment: P_20170403_214140.jpg added

KDL

comment:2 by michaelvoliveira, 2 years ago

Processor Intel i5-6600

comment:3 by axeld, 2 years ago

Component: Servers/app_serverSystem/Kernel
Owner: changed from axeld to nobody
Status: newassigned

That does sound like some memory corruption. Do you know what resolution you are using by default, and which one do you select manually in safe mode? What safe mode options are you using, anyway?

comment:4 by michaelvoliveira, 2 years ago

Hi Axel! I selected the first one "safe mode" option and the "standard vga" option to boot.

Using only "ignore 4mb limit" or another safe mode option did not work.

A funny thing I noticed is that after kdl, if I reset the pc, the pendrive does not appear in the bios boot options. Is necessary to restart one more time.

Default resolution - 1920x1080 32b 8 mb ram motherboard Centriun C2016-H110-H-D3

comment:5 by michaelvoliveira, 2 years ago

Lines 4 and 5 maybe

<kernel_x86> kernel_debugger_loop(0x8018f277 "PANIC: ", 0801a5f20 "vm_page_fault: unhandled page fault in kernel space at 0x%1x, ip 0x%1x ", 0x81b9e6fc "", int32: 2) + 0x20f
<kernel_x86> kernel_debugger_internal(0x8018f277 "PANIC: ", 0801a5f20 "vm_page_fault: unhandled page fault in kernel space at 0x%1x, ip 0x%1x ", 0x81b9e6fc "", int32: 2) + 0x77

It's impossible to get a syslog with usb keyboard...

Last edited 2 years ago by michaelvoliveira (previous) (diff)

by michaelvoliveira, 2 years ago

Attachment: P_20170407_135606.jpg added

KDL

comment:6 by diver, 2 years ago

It looks as if packagefs failed to properly unpack haiku package for some reason.

comment:7 by pulkomandy, 2 years ago

Has a Patch: unset

comment:8 by michaelvoliveira, 14 months ago

Ping

Still there in hrev52084 .... :(

comment:9 by waddlesplash, 14 months ago

Is there any PM hrev that does work?

comment:10 by michaelvoliveira, 14 months ago

@waddlesplash

Pre PM
hrev46000 don't find any partitions

Post PM
hrev47479 don't find any partitions
hrev49662 don't find any partitions
hrev50357 don't find any partitions
hrev50544 the bug


So.. it's beetween hrev50357 and hrev50544, because hrev51061 is this report...
Maybe when updating ACPICA to 20160729 waspossible to boot then hangs
https://git.haiku-os.org/haiku/commit/?h=hrev50544&id=74ffd18dd53b066d1c529b1e877e5a0d2dd66aa6

Last edited 14 months ago by michaelvoliveira (previous) (diff)

comment:11 by waddlesplash, 14 months ago

Keywords: boot-failure added; app_server removed

#14098 looks similar.

comment:12 by michaelvoliveira, 14 months ago

Seems identical to me

comment:13 by waddlesplash, 14 months ago

Blocking: 14098 added

comment:14 by michaelvoliveira, 11 months ago

@waddlesplash Update: boots on Beta1, but without Wlan Atheros AR9287 ...

comment:15 by diver, 11 months ago

Resolution: fixed
Status: assignedclosed

Thanks for the update.

comment:16 by bullfrog, 11 months ago

Thanks for the fix. I had submitted duplicate ticket #14098. Just confirmed. Works here on beta release.

Note: See TracTickets for help on using tickets.