Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13442 closed bug (no change required)

Artpaint crashes

Reported by: michel Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Specifically when calling ClipDinger. To replicate:

Launch a graphic in Artpaint scale it (or edit it some other way, I suppose) click File | Save Image As ... Activate Clipdinger with SHT-ALT-V double-click on Clipdinger item

This sequence of actions consistently crashes Artpaint in hrev51065, using the versions of Artpaint and Clipdinger in the hrev.

Attachments (1)

ArtPaint-2237-debug-24-04-2017-16-23-49.report (99.9 KB ) - added by humdinger 3 years ago.
ArtPaint crash in file panel

Download all attachments as: .zip

Change History (5)

comment:1 by michel, 3 years ago

apologies for bad formatting of ticket text. didn't look like that in the editing window.

comment:2 by diver, 3 years ago

Resolution: no change required
Status: newclosed

ArtPaint is not part oh Haiku. Please create a ticket at https://github.com/HaikuArchives/ArtPaint/issues and attach a debug report

comment:3 by humdinger, 3 years ago

For me, it crashes even right after invoking Clipdinger with SHIFT+ALT+V, attached the backtrace. Opening Clipdinger and double-clicking a clip, doesn't insert it, but also doesn't crash ArtPaint...

No idea who's at fault here. I suspect ArtPaint with its customized file panel, but I'm not sure...

by humdinger, 3 years ago

ArtPaint crash in file panel

comment:4 by humdinger, 3 years ago

BTW, duplicate of #12721. Which I reported... :o

Note: See TracTickets for help on using tickets.