Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#13465 closed bug (invalid)

Paladin/PalEdit 1.3 fails to launch due to missing library in latest Haiku nightly (hrev51139)

Reported by: dcatt Owned by: nobody
Priority: high Milestone: Unscheduled
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: x86-64

Description

I updated to the latest nightly release (hrev51139) and noticed that Paladin/PalEdit 1.3 fails to launch due to a missing library. I have not had issues with this application up to this point with Haiku nightly builds. See the attached screenshots for more details''

STEPS TO REPRODUCE

  • prerequisites;
    • install the latest of Haiku nightly build (hrev51139 or greater)
    • install Paladin 1.3
  1. boot into Haiku
  2. attempt to launch Paladin
  3. (BUG) observe that Paladin fails to launch due to a missing library
  4. attempt to launch PalEdit
  5. (BUG) observe that PalEdit fails to launch due to a missing library

EXPECTED RESULTS

I would expect that Paladin/PalEdit to launch and function on Haiku without issue.

ACTUAL RESULTS

Currently, Paladin/PalEdit 1.3 fails to launch and function on the latest of Haiku nightly builds due to a missing library.

Attachments (5)

Paladin launch failure.png (241.8 KB) - added by dcatt 2 years ago.
PalEdit launch failure.png (241.3 KB) - added by dcatt 2 years ago.
Paladin missing library error in detail.png (171.0 KB) - added by dcatt 2 years ago.
PalEdit missing library in detail.png (171.0 KB) - added by dcatt 2 years ago.
Paladin.1.3.pkg.zip (2.4 MB) - added by dcatt 2 years ago.

Change History (15)

Changed 2 years ago by dcatt

Attachment: Paladin launch failure.png added

comment:1 Changed 2 years ago by dcatt

Has a Patch: set

Changed 2 years ago by dcatt

Attachment: PalEdit launch failure.png added

Changed 2 years ago by dcatt

Changed 2 years ago by dcatt

comment:2 Changed 2 years ago by axeld

The important information is that it obviously tries to link against libpcre.so. This library is not part of the base installation, and 3rd party applications must not assume otherwise.

Of course, if the software contains the library, that would hint to some other problem. I can't check right now, so I'm keeping the ticket open for now.

comment:3 Changed 2 years ago by pulkomandy

You can install libpcre or libpcre0 using pkgman. One of them could help.

comment:4 Changed 2 years ago by humdinger

Resolution: invalid
Status: newclosed

Since Paladin for gcc2 was behind the versions for 64bit and gcc5, I built and updated it in HaikuDepot. Maybe the old package was incorrectly built? In any case, this would be a haikuports issue. Closing, but thanks for the heads-up!

comment:5 Changed 2 years ago by axeld

I think the package that is attached to this ticket is an old BeOS package, not an HPKG.

comment:6 Changed 2 years ago by dcatt

I got that package off of DarkWyrm's BeEmulated website a few years ago IIRC. That's the version of Paladin I run on Haiku A4 and always re-install when I update my Haiku Nightly instance (once a month).

Regarding the missing library... I have not had that issue with past Haiku nightly builds and wondered if that library was removed from the base installation of Haiku?

Last edited 2 years ago by dcatt (previous) (diff)

comment:7 Changed 2 years ago by axeld

I've deleted the .pkg, as I Haiku reports it to be an invalid package file. Can you upload it again zipped first? Otherwise, a link would work fine in this case, too.

Changed 2 years ago by dcatt

Attachment: Paladin.1.3.pkg.zip added

comment:8 Changed 2 years ago by dcatt

axeld... as you requested, zipped .pkg added.

comment:9 Changed 2 years ago by diver

As Pulkomandy said you probably need to pkgman install libpcre0. Maybe it was included in Haiku A4 by default but not anymore.

comment:10 Changed 2 years ago by dcatt

diver, I install the latest Haiku nightly at the beginning of each month and been doing so for years and have not ever run into this issue ever until this past weekend.

Note: See TracTickets for help on using tickets.