Opened 2 years ago

Closed 4 months ago

#13574 closed bug (duplicate)

[package_daemon] activate packages after replace

Reported by: diver Owned by: bonefish
Priority: normal Milestone: Unscheduled
Component: Servers/package_daemon Version: R1/Development
Keywords: Cc:
Blocked By: #15068 Blocking:
Has a Patch: no Platform: All

Description

Patch from #10038 fixed the issue however now replacing a package (with the same name) doesn't activate the new one.

Change History (6)

comment:1 by waddlesplash, 2 years ago

Huh? Unless I missed something, that should only happen if you replace a package with the *exact* same name, i.e. the version+revision is the same. If the package has a newer revision, it should get activated.

comment:2 by luroh, 2 years ago

Yes, that's what diver wrote. This new behavior does not strike me as intuitive.

comment:3 by throttle10, 2 years ago

Huh? Unless I missed something, that should only happen if you replace a package with the *exact* same name, i.e. the version+revision is the same. If the package has a newer revision, it should get activated.

Yes, name is the same. i'm trying to fix it by adding reactivating possibility to package_daemon. Packagefs already supports it.

Last edited 2 years ago by throttle10 (previous) (diff)

comment:4 by axeld, 2 years ago

What is the point of doing that? Just to repeatedly test a package you build yourself? What am I missing here? :-)

comment:5 by diver, 2 years ago

The original point is exactly that :-) But there might be other use cases, who knows?

comment:6 by waddlesplash, 4 months ago

Blocked By: 15068 added
Resolution: duplicate
Status: newclosed

Now that the causes are better understood, #15068 is a dupe of this, but that one has more details.

Note: See TracTickets for help on using tickets.