#13642 closed bug (fixed)

Web+ Redirection failure

Reported by: humdinger Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by humdinger)

This is hrev51318, gcc2h.

At https://www.haiku-os.org/documents/ the HIG is linking to https://api.haiku-os.org/docs/HIG/index.xml which should redirect to https://www.haiku-os.org/docs/HIG/index.xml

QuipZilla does so, Web+ doesn't.

Change History (8)

comment:2 Changed 22 months ago by humdinger

Description: modified (diff)
Summary: Issue rendering HIG page index.xmlWeb+ Redirection failure

Indeed, that URL works. Means a) the URL at https://www.haiku-os.org/documents/ is 'wrong' and b) since Qupzilla is redirected correctly, something's still not perfect with Web+'s redirection. Changing description.

comment:4 Changed 22 months ago by pulkomandy

A terminal log with libbnetapi in debug mode could provide some info.

I guess a redirection happens (as we get the contents eventually) but WebKit isn't noticed that the URL has changed. As a result it uses the wrong "base" URL for various things, and in this case, it includes the XSLT stylesheet which is used to do all of the formatting, as well as the CSS, I guess.

May be a similar problem that leads to missing images in the API docs.

comment:5 Changed 22 months ago by accessays

Redirecting works just fine for me (text and formatting identical to Firefox), hrev51308 (with patch from hrev51314 applied), x86_64, so the problem is probably either gcc2h specific or some regression introduced between these revisions.

comment:6 Changed 22 months ago by pulkomandy

It can also be yet another race condition, in that case it depends on the network speed and CPU performance and system load. Which makes these things annoying to debug as usually adding some debug output will "fix" the problem.

comment:7 Changed 16 months ago by korli

Isn't this fixed already?

comment:8 Changed 16 months ago by humdinger

Resolution: fixed
Status: newclosed

Indeed, https://api.haiku-os.org/docs/HIG/index.xml redirects to https://www.haiku-os.org/docs/api/docs/HIG/index.xml which now 404s, but that's not the issue. This is with hrev51770.

Let's close the ticket, before PulkoMandy publishes his next release and seizes the chance to break redirection again. :)

Note: See TracTickets for help on using tickets.