Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#13652 closed bug (no change required)

pkgman full-sync ignores local packages by considering old version on the repo

Reported by: Giova84 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Kits/Package Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Sorry for the long title, I didn't know how to better describe the title.

I'm on Haiku hrev51336 gcc2h but I also see this behaviour on old revisions.

I have an upgraded package of qBittorrent (3.2.3-3 instead of 3.2.3-2) which also has a different "requires" section in the .PackageInfo file.

Well, today I'd attempt to run pkgman full-sync which immediately give me an error:

Encountered problems:
problem 1: nothing provides lib:libtorrent_rasterbar_x86>=1.0.6 needed by qbittorrent_x86-3.2.3-2
  solution 1:
    - keep qbittorrent_x86-3.2.3-3 from excluded repository

The fact is that: first of all I have libtorrent_rasterbar_x86-1.0.9-1-x86_gcc2.hpkg instead of libtorrent_rasterbar_x86-1.0.6-2-x86_gcc2.hpkg

And the second one is that I have qBittorrent 3.2.3-3 instead of 3.2.3-2, which also, in the .PackageInfo file just require lib:libtorrent_rasterbar_x86.

I know that I also should set the version of the required lib, but this package which I built is just a temporary workaround; however pkgman seems that doesn't consider local packages and confuses them with packages on the online repo, also if these are old revision.

I tried by uninstalling the qbittorrent package and the error message is gone, but I give up with "full-sync" since, furthermore, it wants to downgrade a lot of packages..

Change History (2)

comment:1 by korli, 2 years ago

Resolution: no change required
Status: newclosed

To do a "full-sync", pkgman tries to install qbittorrent_x86-3.2.3-2, which is the available version in the depot. This version depends on libtorrent_rasterbar_x86-1.0.6-2 which the depot doesn't provide (only libtorrent_rasterbar_x86-1.0.9-1). Thus pkgman proposes to leave things as is.

The repository is simply inconsistent. What doesn't help is that libtorrent_rasterbar_x86-1.0.6-2 is incompatible with libtorrent_rasterbar_x86-1.0.9-1, because the soname changed.

The behaviour is valid, no package kit change required.

comment:2 by Giova84, 2 years ago

Thanks for the explanation.

Note: See TracTickets for help on using tickets.