#13706 closed bug (fixed)

Deskbar's "Tracker always first" broken

Reported by: humdinger Owned by: jscipione
Priority: normal Milestone: Unscheduled
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev51414.

After the recent - much appreciated - introduction of a resizable Deskbar, Deskbar's "Tracker always first" shows an interesting breakage. When the option is activated, and Tracker's "Expando" widget points down, i.e. open Tracker windows are listed, opening Tracker windows result in their entries appearing and disappearing under Tracker and another app's Deskbar entry.

See the attached movie.

Attachments (1)

Merry-go-around.avi (3.2 MB) - added by humdinger 22 months ago.
Entries dis/appearing

Change History (9)

Changed 22 months ago by humdinger

Attachment: Merry-go-around.avi added

Entries dis/appearing

comment:1 Changed 22 months ago by diver

Same here.

comment:2 Changed 22 months ago by jscipione

Was able to reproduce.

Must have following Deskbar settings turned on:

  • Sort applications by name
  • Tracker always first
  • Show application expander

Tracker must have at least 1 window open, and must be expanded (arrow down) Deskbar must have another app running that has a Deskbar entry.

Fun little bug you've found. Appears to be an infinite loop somewhere.

Last edited 22 months ago by jscipione (previous) (diff)

comment:3 Changed 22 months ago by jscipione

Fix applied in hrev51421 please retest and report back here

comment:4 Changed 22 months ago by jscipione

Fix in hrev51421 reverted, hold off on retest

comment:5 Changed 22 months ago by jscipione

Fixed again in hrev51425 please retest and report back here

The infinite loop should now be gone.

When you check and uncheck "Tracker always first" Deskbar does a little dance as it resorts the app and window lists. I will look into getting rid of this dance next.

comment:6 Changed 14 months ago by humdinger

Not sure why I haven't commented yet, but I confirm the loop's gone. Left is the bit of shuffling around you mentioned in the last comment. It's not really related to the "Tracker first" option, but sorting in general, i.e. "Sort applications by name" triggers it too.

comment:7 Changed 13 months ago by jscipione

I'm not sure what changed but the shuffling around of items seems to be fixed now

comment:8 Changed 13 months ago by humdinger

Resolution: fixed
Status: newclosed

Yep. Cannot reproduce anymore either. Closing ticket as fixed (somehow).

Note: See TracTickets for help on using tickets.