Opened 12 years ago

Closed 12 years ago

#1378 closed bug (fixed)

[Tracker] double click runtime_loader to freeze tracker

Reported by: diver Owned by: stippi
Priority: normal Milestone: R1
Component: System/runtime_loader Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Boot Haiku Navigate Haiku->beos->system. Doube click runtime_loader, doube click runtime_loader again. Right click runtime_loader. Haiku will freeze. Tested with vmware hrev21884 under linux.

Change History (4)

comment:1 by diver, 12 years ago

From serial port:

vm_soft_fault: va 0x220 not covered by area in address space vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x220, ip 0x29106c, write 1, user 1, thread 0x7b vm_page_fault: sending team "/boot/beos/system/servers/app_s" 0x23 SIGSEGV, ip 0x29106c ("app_server_seg0ro" +0x9106c) stack trace:

0x00286a86 (app_server_seg0ro + 0x86a86) 0x0027a0d4 (app_server_seg0ro + 0x7a0d4) 0x0027a131 (app_server_seg0ro + 0x7a131) 0x0027f074 (app_server_seg0ro + 0x7f074) 0x0027d05f (app_server_seg0ro + 0x7d05f) 0x0027681a (app_server_seg0ro + 0x7681a) 0x0025b31c (app_server_seg0ro + 0x5b31c) 0x007257d0 (libroot.so_seg0ro + 0x207d0) 0x70553fec (w:61:TrackerWindow_7b_stack + 0x3ffec)

vm_soft_fault: va 0x0 not covered by area in address space vm_page_fault: vm_soft_fault returned error 'Bad address' on fault at 0x0, ip 0x80094e1c, write 0, user 0, thread 0x7b debug_server: Thread 123 entered the debugger: Segment violation stack trace, current PC 0x29106c FillRectNoClippingC7PainterRC5BRectRC9rgb_color + 0x10c:

(0x70553d40) 0x286a86 FillRegion13DrawingEngineR7BRegionRC8RGBColor + 0xf2 (0x70553dbc) 0x27a0d4 Draw9ViewLayerP13DrawingEngineP7BRegionT2b + 0x520 (0x70553e2c) 0x27a131 Draw9ViewLayerP13DrawingEngineP7BRegionT2b + 0x57d (0x70553eac) 0x27f074 _TriggerContentRedraw11WindowLayerR7BRegion + 0xe0 (0x70553efc) 0x27d05f RedrawDirtyRegion11WindowLayer + 0x77 (0x70553f3c) 0x27681a _MessageLooper12ServerWindow + 0x126 (0x70553f7c) 0x25b31c _message_thread13MessageLooperPv + 0x28 (0x70553fac) 0x7257d0 _get_next_team_info + 0x5c (closest symbol)

comment:2 by bonefish, 12 years ago

Component: System/runtime_loaderServers/app_server
Owner: changed from axeld to stippi

If you paste output into a comment please make sure to enclose it in a {{{ ... }}} block. Otherwise it gets wikified and less readable. Thanks.

Anyway, this doesn't seem to have much to do with Tracker or the runtime loader. Obviously the app server crashes. Reassigning to stippi, since he has been waiting for a real app server crash for quite some time. ;-)

BTW, I can't reproduce the problem here, but I can perfectly reproduce a kernel deadlock with this test case (#1379).

comment:3 by diver, 12 years ago

Can't reproduce, maybe fixed in the meantime.

comment:4 by axeld, 12 years ago

Component: Servers/app_serverSystem/runtime_loader
Resolution: fixed
Status: newclosed

I think I did that once :-)

Note: See TracTickets for help on using tickets.