Opened 3 years ago

Closed 2 months ago

Last modified 2 months ago

#13803 closed bug (fixed)

Strange behavior involving pressing ctrl+c on a selected url in WebPositive

Reported by: WildKeccak Owned by: pulkomandy
Priority: normal Milestone: R1/beta2
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

It messes up the back and forward navigation buttons too.

Change History (8)

comment:1 by diver, 3 years ago

Component: - GeneralApplications/Workspaces
Keywords: ctrl c url navigation WebPositive removed
Owner: changed from nobody to axeld

comment:2 by WildKeccak, 4 months ago

You can press ctrl+c anywhere in the url and it will unkindly make the current URL permanent.

comment:3 by humdinger, 4 months ago

I'm not able to reproduce this (hrev53900, 32bit). Can you give step-by-step instructions (or a screencapture, maybe)?

comment:4 by Starcrasher, 2 months ago

Why Workspace component? It seems to me that only WebPositive is involved.

WildKeccak, what do you mean by permanent? Does it create a bookmark?
It would help to know what version of Haiku you are using. You can see that on left panel of "About Haiku" window.

Maybe an old bug when Web+ was reopening on same page after a crash? Ctrl+c being cause of the crash.
I'm not able to reproduce it under (hrev54109, 64bit).
I thought it could be that ctrl key was not mapped correctly and so I tried with Ctrl+c Opt+c and Cmd+c.
Ctrl+C, cleared the address field.
Opt+C, put a copyright sign in adress field.
Cmd+C, copied the content in clipboard.
I tried selecting links in other places, the page shown, history, bookmarks... without encountering the problem.
Since humdinger didn't notice problems either in 32 bit, whatever it was, seems fixed in recent hrevs.

comment:5 by pulkomandy, 2 months ago

Component: Applications/WorkspacesApplications/WebPositive
Owner: changed from axeld to pulkomandy

I guess someone picked the wrong item in the component list.

comment:6 by WildKeccak, 2 months ago

I agree. I was not able to reproduce this in hrev54051 x86_64 either

comment:7 by waddlesplash, 2 months ago

Resolution: fixed
Status: newclosed

comment:8 by nielx, 2 months ago

Milestone: UnscheduledR1/beta2

Assign tickets with status=closed and resolution=fixed within the R1/beta2 development window to the R1/beta2 Milestone

Note: See TracTickets for help on using tickets.