Opened 3 years ago

Closed 3 years ago

Last modified 4 months ago

#13809 closed enhancement (no change required)

HaikuDepot: Show a statusbar loading the packages before the user can select anything

Reported by: lelldorin Owned by: stippi
Priority: normal Milestone:
Component: Applications/HaikuDepot Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Platform: All

Description

I have sience HaikuDepot comes out the problem that the programs is crashing or freeze during the loading of the packages to display in the app selection.

that is extremely annoying

Here my enhancement: Why not using a stackview and during loading the packages, displaying a statusbar of loading the program infomrations. Then switching to the user interface. This should fix this problem.

I use this many times for my own projects.

Change History (5)

comment:1 by diver, 3 years ago

Component: - GeneralApplications/HaikuDepot
Keywords: haikudepot slow crash statusbar removed
Owner: changed from nobody to stippi

Please attach a crash report otherwise this bug report is not very helpful. WRT status bar - it was implemented yesterday, so update your Haiku to see it in action.

in reply to:  1 comment:2 by lelldorin, 3 years ago

Replying to diver:

Please attach a crash report otherwise this bug report is not very helpful. WRT status bar - it was implemented yesterday, so update your Haiku to see it in action.

It is not a bug report it is a wish for a enhancement in the future

comment:3 by diver, 3 years ago

Resolution: no change required
Status: newclosed

This is fixed already then.

comment:4 by lelldorin, 14 months ago

[DE]Das ist nicht nur ein vorschlag für spätere versionen und es wurde auch schon in einige verbesserungen eingebaut, aber noch immer stürzt HaikuDepot ab, wenn man beim aufbau der Anwendungsliste eine diese anklickt. Ich habe kein neues system, daher dauert der ladevorgang vermutlich länger wie bei den meisten hier, und der fehler fällt dann dort nicht so auf wie bei mir.

[UK]This is not only a suggestion for later versions and it has already been incorporated into some improvements, but HaikuDepot still crashes if you click this one while building the application list. I do not have a new system, so it will probably take longer to load than most of them here, and then the error will not be there as it is for me.

comment:5 by nielx, 4 months ago

Milestone: Unscheduled

Remove milestone for tickets with status = closed and resolution != fixed

Note: See TracTickets for help on using tickets.