#13821 closed bug (not reproducible)

gnuefi package is a build requirement for UEFI

Reported by: tqh Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Someone created a gnu_efi_kernel package but never switched the build over to it. And now the gnuefi package is not a requirement and doesn't exist.

I want to find whoever was working on this so we can sync on the proper fix...

Change History (5)

comment:1 Changed 20 months ago by waddlesplash

I saw the package change but I didn't have time to properly investigate if the packages really were the same, just renamed, or if something else changed in the process. I'll have time to look into this today, unless you already have.

comment:2 Changed 20 months ago by tqh

Tried to switch to new one in build/jam/BuildFeatures, but it fails to find files, so need to figure out how they are different. Problem is I don't have old package or the definition of the old package.

comment:3 Changed 20 months ago by tqh

If you are looking at it, maybe you can make naming better we have gnuefi, gnu-efi, gnu_efi atm, seems messy.

comment:4 Changed 20 months ago by waddlesplash

I don't either, it looks like it's not in HaikuPorts, which is weird. I'm not sure about the naming issue. Yes, I can look later today.

comment:5 Changed 13 months ago by tqh

Resolution: not reproducible
Status: newclosed

I don't know who or when it was fixed but it hasn't been an issue for a long time.

Note: See TracTickets for help on using tickets.