Opened 4 years ago

Closed 3 years ago

Last modified 20 months ago

#13839 closed bug (duplicate)

Haiku can not boot with usb installation

Reported by: dillcn Owned by: nobody
Priority: normal Milestone:
Component: Drivers/USB/XHCI Version: R1/Development
Keywords: boot-failure Cc:
Blocked By: #13772 Blocking:
Platform: x86-64

Description

I install hrev51658 64bit image to usb disk, it can not boot on lenovo PC, and stop at the 3rd icon .Then I enable screen debug, the debug log as attached image.

Attachments (2)

lenovo-pc-boot.jpg (3.8 MB ) - added by dillcn 4 years ago.
lenovo pc boot debug log
image2-disable-local-APIC-and-SMP.jpg (3.3 MB ) - added by dillcn 4 years ago.
disable local APIC and SMP

Change History (16)

by dillcn, 4 years ago

Attachment: lenovo-pc-boot.jpg added

lenovo pc boot debug log

comment:1 by dillcn, 4 years ago

patch: 01

comment:2 by diver, 4 years ago

patch: 10

comment:3 by diver, 4 years ago

Does booting just stop at the last line in that pic or there are more lines after that? Try disabling local APIC or SMP in the boot loader.

in reply to:  3 comment:4 by dillcn, 4 years ago

Replying to diver:

Does booting just stop at the last line in that pic or there are more lines after that? Try disabling local APIC or SMP in the boot loader.

I did not pay attention on this, I will try another day. Just now, I tried this usb disk on an old laptop lenovo F41A, something interesting happened, it boot to desktop. But the image I burn to usb disk is 64bit, and my old laptop I think is just 32bit (Intel dual core T5250 1.5GHz), I do not know why this usb disk can not boot on a new 64bit PC but old 32bit laptop.

in reply to:  3 comment:6 by dillcn, 4 years ago

Replying to diver:

Does booting just stop at the last line in that pic or there are more lines after that? Try disabling local APIC or SMP in the boot loader.

Yes, it was stop at the last line in that pic, and I pressed space it was not continue.

I disabled local APIC and SMP, screen debug log as image2-disable-local-APIC-and-SMP.jpg.

by dillcn, 4 years ago

disable local APIC and SMP

comment:7 by dillcn, 4 years ago

patch: 01

comment:8 by dillcn, 4 years ago

I did not set "Has a Patch", is it default?

comment:9 by pulkomandy, 4 years ago

patch: 10

comment:10 by pulkomandy, 4 years ago

Yes, an annoying bug in our Trac hack to manage patches.

comment:11 by waddlesplash, 3 years ago

Keywords: boot-failure added

comment:12 by waddlesplash, 3 years ago

Please retest with a recent nightly build.

comment:13 by waddlesplash, 3 years ago

Blocked By: 13772 added
Resolution: duplicate
Status: newclosed

Just realized this is a duplicate of #13772 ("unsuccessful command Parameter").

comment:14 by nielx, 20 months ago

Milestone: Unscheduled

Remove milestone for tickets with status = closed and resolution != fixed

Note: See TracTickets for help on using tickets.