#13850 closed bug (no change required)

KeymapSwitcher is not installed in Deskbar

Reported by: Lan72 Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: - General Version: R1/Development
Keywords: Deskbar, KeymapSwitcher Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

After the last updates of the night builds, starting somewhere from hrev51659-60, KeymapSwitcher ceased to be installed in Deskbar. It's impossible to install in Deskbar and earlier versions of KeymapSwitcher.

When restart or shutdown computer, Deskbar crashes and gives an error. Debug information is attached. Perhaps the problem is not in KeymapSwitcher, but in the last night builds? But all other programs, as before, are quite successfully installed in Deskbar.

Attachments (1)

Deskbar-26271-debug-08-12-2017-22-15-40.report (13.2 KB) - added by Lan72 20 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 20 months ago by Lan72

Has a Patch: set

comment:2 Changed 20 months ago by diver

I have no problems with KeymapSwitcher in hrev51653. Deskbar doesn't crash too...

comment:3 Changed 20 months ago by luroh

There is no KeymapSwitcher in /boot/system/preferences, and the link to KeymapSwitcher in the Preferences menu is broken. Uninstalling and reinstalling KeymapSwitcher seems to solve the problem.

Tested with a fresh gcc2h @nightly-vmware, hrev51665.

comment:4 Changed 20 months ago by Lan72

Repeatedly reinstalled KeymapSwitcher, because it's obvious. Nothing helps. And why do you think that KeymapSwitcher is not in /boot/system/preferences? The fact of the matter is that she is there...

comment:5 Changed 20 months ago by luroh

I think you misunderstand, I simply confirm that there is something strange going on with KeymapSwitcher and provide steps to repeat.

comment:6 Changed 20 months ago by luroh

Works for me again with hrev51669.

comment:7 Changed 19 months ago by Lan72

The question is removed. The problem was in the invalid or corrupted Switcher settings file in /boot/home/config/settings. After its removal and restarting Deskbar, the KeymapSwitcher perfectly installed in Deskbar.

Many thanks to everyone who responded to my problem.

comment:8 Changed 19 months ago by diver

Resolution: no change required
Status: newclosed

Thanks for the update. Closing.

Note: See TracTickets for help on using tickets.