Opened 22 months ago

Last modified 21 months ago

#13856 new bug

Webpositive is missing trailing dots in menus

Reported by: konrad Owned by: pulkomandy
Priority: normal Milestone: Unscheduled
Component: Applications/WebPositive Version: R1/Development
Keywords: Missing dots in meny Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I think settings in menu should have trailing dots.

Settings...

Attachments (1)

Skärmavbild 2017-12-11 kl. 11.32.04.png (84.2 KB ) - added by konrad 22 months ago.
Screenshot

Download all attachments as: .zip

Change History (6)

by konrad, 22 months ago

Screenshot

comment:1 by konrad, 22 months ago

Has a Patch: set

comment:2 by pulkomandy, 22 months ago

Correct as per the current HIG (https://www.haiku-os.org/docs/HIG/index.xml), but IIRC we wanted to rephrase this.

The definition should be something like this:

"If the menu action is completed immediately, no ellipsis should be used. If the action will require further user input, an ellipsis should be used."

So, an "Open" menu which needs extra input (from a file dialog) would get an ellipsis. But the action of a "Settings" menu is just opening the settings window. The action is immediately complete.

comment:3 by konrad, 22 months ago

Hi PulkoMandy!

See Common Menus and their Contents. I would interpretate that as "About, Settings, etc" should have trailing ellipsis's.

comment:4 by pulkomandy, 22 months ago

Yes, as I said your ticket agrees with the current wording of the HIG. I thought we had changed the HIG already but apparently we only discussed this and then the document was not updated. Will consider it again on the mailing list, I guess.

comment:5 by pulkomandy, 21 months ago

Has a Patch: unset
Note: See TracTickets for help on using tickets.